4 Replies Latest reply on Feb 14, 2012 5:24 PM by Amol Chaudhari

    fuse ESB 4.4 installation error

    chandraprabha rajput Novice

      Hi All,

       

      When trying to  run  servicemix.bat I am getting the below error

       

      Please advice.

       

      ERROR: Error parsing system bundle export statement: org.osgi.framework; version=1.5.0, org.osgi.framework.launch; version=1.0.0, org.osgi.framework.hooks.service; version=1.0.0, org.osgi.service.packageadmin; version=1.2.0, org.osgi.service.startlevel; version=1.1.0, org.osgi.service.url; version=1.0.0, org.osgi.util.tracker; version=1.4.0, org.apache.karaf.jaas.boot; version=2.2.0.fuse-00-43, org.apache.karaf.version; version=2.2.0.fuse-00-43, ,org.apache.karaf.branding, com.sun.org.apache.xalan.internal.xsltc.trax, com.sun.org.apache.xerces.internal.dom, com.sun.org.apache.xerces.internal.jaxp, com.sun.org.apache.xerces.internal.xni, com.sun.jndi.ldap, org.apache.xalan.extensions; version="2.7.1", org.apache.xalan.xsltc.compiler; version="2.7.1", org.apache.xalan.xsltc.cmdline.getopt; version="2.7.1", org.apache.xalan.xsltc.util; version="2.7.1", org.apache.xalan.transformer; version="2.7.1", org.apache.xalan.xsltc.trax; version="2.7.1", org.apache.xalan.processor; version="2.7.1", org.apache.xalan.lib; version="2.7.1", org.apache.xalan.trace; version="2.7.1", org.apache.xalan.xsltc.compiler.util; version="2.7.1", org.apache.xalan.templates; version="2.7.1", org.apache.xalan.xsltc; version="2.7.1", org.apache.xalan.xsltc.runtime; version="2.7.1", org.apache.xalan; version="2.7.1", org.apache.xalan.xslt; version="2.7.1", org.apache.xalan.lib.sql; version="2.7.1", org.apache.xalan.xsltc.runtime.output; version="2.7.1", org.apache.xalan.xsltc.dom; version="2.7.1", org.apache.xalan.client; version="2.7.1", org.apache.xalan.xsltc.cmdline; version="2.7.1", org.apache.xalan.serialize; version="2.7.1", org.apache.xalan.res; version="2.7.1", org.apache.xml.dtm.ref; version="2.7.1", org.apache.xml.dtm; version="2.7.1", org.apache.xml.dtm.ref.sax2dtm; version="2.7.1", org.apache.xml.dtm.ref.dom2dtm; version="2.7.1", org.apache.xml.res; version="2.7.1", org.apache.xml.serializer.dom3; version="2.7.1", org.apache.xml.serializer; version="2.7.1", org.apache.xml.serializer.utils; version="2.7.1", org.apache.xml.utils.res; version="2.7.1", org.apache.xml.utils; version="2.7.1", org.apache.xpath.functions; version="2.7.1", org.apache.xpath.jaxp; version="2.7.1", org.apache.xpath.patterns; version="2.7.1", org.apache.xpath.objects; version="2.7.1", org.apache.xpath.res; version="2.7.1", org.apache.xpath; version="2.7.1", org.apache.xpath.axes; version="2.7.1", org.apache.xpath.compiler; version="2.7.1", org.apache.xpath.operations; version="2.7.1", org.apache.xpath.domapi; version="2.7.1", org.apache.html.dom; version="2.11.0", org.apache.wml.dom; version="2.11.0", org.apache.wml; version="2.11.0", org.apache.xerces.parsers; version="2.11.0", org.apache.xerces.impl.dtd.models; version="2.11.0", org.apache.xerces.xni.parser; version="2.11.0", org.apache.xerces.impl.dv.xs; version="2.11.0", org.apache.xerces.impl.xs.traversers; version="2.11.0", org.apache.xerces.util; version="2.11.0", org.apache.xerces.impl.dtd; version="2.11.0", org.apache.xerces.jaxp.validation; version="2.11.0", org.apache.xerces.dom3.as; version="2.11.0", org.apache.xerces.impl.dv; version="2.11.0", org.apache.xerces.jaxp; version="2.11.0", org.apache.xerces.jaxp.datatype; version="2.11.0", org.apache.xerces.impl.xpath.regex; version="2.11.0", org.apache.xerces.xni; version="2.11.0", org.apache.xerces.impl.msg; version="2.11.0", org.apache.xerces.impl.dv.util; version="2.11.0", org.apache.xerces.impl.xs.util; version="2.11.0", org.apache.xerces.dom; version="2.11.0", org.apache.xerces.dom.events; version="2.11.0", org.apache.xerces.impl.xs.opti; version="2.11.0", org.apache.xerces.impl; version="2.11.0", org.apache.xerces.xs; version="2.11.0", org.apache.xerces.impl.io; version="2.11.0", org.apache.xerces.xpointer; version="2.11.0", org.apache.xerces.impl.dv.dtd; version="2.11.0", org.apache.xerces.xinclude; version="2.11.0", org.apache.xerces.impl.xpath; version="2.11.0", org.apache.xerces.xs.datatypes; version="2.11.0", org.apache.xerces.impl.xs.identity; version="2.11.0", org.apache.xerces.impl.xs.models; version="2.11.0", org.apache.xerces.xni.grammars; version="2.11.0", org.apache.xerces.impl.xs; version="2.11.0", org.apache.xerces.impl.validation; version="2.11.0", org.apache.xml.serialize; version="2.11.0", (java.lang.IllegalArgumentException: No paths specified in header: )

      ERROR: Bundle org.ops4j.pax.url.wrap Error starting mvn:org.ops4j.pax.url/pax-url-wrap/1.2.6 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.url.wrap : Unable to resolve 1.0: missing requirement package; (package=javax.net.ssl))

      ERROR: Bundle org.ops4j.pax.url.mvn Error starting mvn:org.ops4j.pax.url/pax-url-mvn/1.2.6 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.url.mvn : Unable to resolve 2.0: missing requirement package; (package=javax.net.ssl))

      ERROR: Bundle org.ops4j.pax.logging.pax-logging-service Error starting mvn:org.ops4j.pax.logging/pax-logging-service/1.6.2 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.logging.pax-logging-service : Unable to resolve 3.0: missing requirement package; (package=javax.xml.parsers))

      ERROR: Bundle org.ops4j.pax.logging.pax-logging-api Error starting mvn:org.ops4j.pax.logging/pax-logging-api/1.6.2 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.ops4j.pax.logging.pax-logging-api : Unable to resolve 4.0: missing requirement package; (package=javax.xml.parsers))

      ERROR: Bundle org.apache.felix.configadmin Error starting mvn:org.apache.felix/org.apache.felix.configadmin/1.2.8-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.configadmin : Unable to resolve 5.0: missing requirement package; (package=javax.security.auth))

      ERROR: Bundle org.apache.felix.bundlerepository Error starting mvn:org.apache.felix/org.apache.felix.bundlerepository/1.6.4 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.bundlerepository : Unable to resolve 6.0: missing requirement package; (&(package=org.osgi.framework)(version>=1.3.0)(!(version>=2.0.0))))

      ERROR: Bundle org.apache.felix.fileinstall Error starting mvn:org.apache.felix/org.apache.felix.fileinstall/3.1.11-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.felix.fileinstall : Unable to resolve 7.0: missing requirement package; (&(package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0))))

      ERROR: Bundle org.apache.aries.proxy Error starting mvn:org.apache.aries.proxy/org.apache.aries.proxy/0.3 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.proxy : Unable to resolve 8.0: missing requirement package; (&(package=org.apache.aries.util)(version>=0.3.0)(!(version>=1.0.0))) [caused by: Unable to resolve 9.0: missing requirement package; (&(package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0)))])

      ERROR: Bundle org.apache.aries.util Error starting mvn:org.apache.aries/org.apache.aries.util/0.3 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.util : Unable to resolve 9.0: missing requirement package; (&(package=org.osgi.framework)(version>=1.5.0)(!(version>=2.0.0))))

      ERROR: Bundle org.apache.aries.blueprint Error starting mvn:org.apache.aries.blueprint/org.apache.aries.blueprint/0.3.1 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.blueprint : Unable to resolve 10.0: missing requirement package; (package=javax.xml.parsers))

      ERROR: Bundle org.apache.karaf.shell.commands Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.commands/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.commands : Unable to resolve 12.0: missing requirement package; (&(package=jline)(version>=2.5.0)(!(version>=3.0.0))) [caused by: Unable to resolve 38.0: missing requirement package; (package=javax.security.auth)])

      ERROR: Bundle org.apache.karaf.deployer.wrap Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.wrap/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.wrap : Unable to resolve 13.0: missing requirement package; (&(package=org.apache.felix.fileinstall)(version>=3.1.0)(!(version>=4.0.0))) [caused by: Unable to resolve 7.0: missing requirement package; (&(package=org.osgi.framework)(version>=1.4.0)(!(version>=2.0.0)))])

      ERROR: Bundle org.apache.karaf.shell.dev Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.dev/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.dev : Unable to resolve 14.0: missing requirement package; (package=javax.net.ssl))

      ERROR: Bundle org.apache.karaf.deployer.kar Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.kar/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.kar : Unable to resolve 15.0: missing requirement package; (package=javax.xml.parsers))

      ERROR: Bundle org.apache.karaf.jaas.modules Error starting mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.modules/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.modules : Unable to resolve 16.0: missing requirement package; (package=javax.naming))

      ERROR: Bundle org.apache.karaf.shell.ssh Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.ssh/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.ssh : Unable to resolve 17.0: missing requirement package; (package=javax.security.auth))

      ERROR: Bundle org.apache.karaf.features.command Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.command/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.command : Unable to resolve 18.0: missing requirement package; (package=javax.management))

      ERROR: Bundle org.apache.karaf.deployer.spring Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.spring/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.spring : Unable to resolve 19.0: missing requirement package; (package=javax.xml.parsers))

      ERROR: Bundle org.apache.karaf.admin.core Error starting mvn:org.apache.karaf.admin/org.apache.karaf.admin.core/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.core : Unable to resolve 20.0: missing requirement package; (package=javax.management))

      ERROR: Bundle org.apache.karaf.shell.osgi Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.osgi/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.osgi : Unable to resolve 21.0: missing requirement package; (&(package=jline)(version>=2.5.0)(!(version>=3.0.0))) [caused by: Unable to resolve 38.0: missing requirement package; (package=javax.security.auth)])

      ERROR: Bundle org.apache.karaf.diagnostic.management Error starting mvn:org.apache.karaf.diagnostic/org.apache.karaf.diagnostic.management/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.diagnostic.management : Unable to resolve 22.0: missing requirement package; (package=javax.management))

      ERROR: Bundle sshd-core Error starting mvn:org.apache.sshd/sshd-core/0.5.0 (org.osgi.framework.BundleException: Unresolved constraint in bundle sshd-core : Unable to resolve 23.0: missing requirement package; (package=javax.crypto))

      ERROR: Bundle org.apache.aries.jmx.blueprint Error starting mvn:org.apache.aries.jmx/org.apache.aries.jmx.blueprint/0.3 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx.blueprint : Unable to resolve 25.0: missing requirement package; (package=javax.management))

      ERROR: Bundle org.apache.karaf.features.management Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.management/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.management : Unable to resolve 26.0: missing requirement package; (package=javax.management))

      ERROR: Bundle org.apache.karaf.diagnostic.common Error starting mvn:org.apache.karaf.diagnostic/org.apache.karaf.diagnostic.common/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.diagnostic.common : Unable to resolve 27.0: missing requirement package; (&(package=org.apache.karaf.features)(version>=2.2.0)(!(version>=3.0.0))) [caused by: Unable to resolve 41.0: missing requirement package; (package=javax.management)])

      ERROR: Bundle org.apache.karaf.admin.management Error starting mvn:org.apache.karaf.admin/org.apache.karaf.admin.management/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.management : Unable to resolve 28.0: missing requirement package; (package=javax.management))

      ERROR: Bundle org.apache.karaf.jaas.command Error starting mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.command/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.command : Unable to resolve 29.0: missing requirement package; (package=javax.management))

      ERROR: Bundle org.apache.karaf.jaas.config Error starting mvn:org.apache.karaf.jaas/org.apache.karaf.jaas.config/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.jaas.config : Unable to resolve 30.0: missing requirement package; (package=javax.net.ssl))

      ERROR: Bundle org.apache.karaf.shell.log Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.log/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.log : Unable to resolve 31.0: missing requirement package; (&(package=org.apache.felix.gogo.commands)(version>=0.6.0)(!(version>=1.0.0))) [caused by: Unable to resolve 38.0: missing requirement package; (package=javax.security.auth)])

      ERROR: Bundle org.apache.karaf.deployer.features Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.features/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.features : Unable to resolve 32.0: missing requirement package; (package=javax.xml.parsers))

      ERROR: Bundle org.apache.karaf.admin.command Error starting mvn:org.apache.karaf.admin/org.apache.karaf.admin.command/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.admin.command : Unable to resolve 33.0: missing requirement package; (package=javax.management))

      ERROR: Bundle org.apache.aries.jmx Error starting mvn:org.apache.aries.jmx/org.apache.aries.jmx/0.3 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.aries.jmx : Unable to resolve 34.0: missing requirement package; (package=javax.management))

      ERROR: Bundle org.apache.karaf.features.obr Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.obr/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.obr : Unable to resolve 35.0: missing requirement package; (&(package=org.apache.felix.bundlerepository)(version>=2.0.0)(!(version>=3.0.0))) [caused by: Unable to resolve 6.0: missing requirement package; (&(package=org.osgi.framework)(version>=1.3.0)(!(version>=2.0.0)))])

      ERROR: Bundle org.apache.karaf.diagnostic.command Error starting mvn:org.apache.karaf.diagnostic/org.apache.karaf.diagnostic.command/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.diagnostic.command : Unable to resolve 36.0: missing requirement package; (&(package=org.apache.felix.gogo.commands)(version>=0.6.0)(!(version>=1.0.0))) [caused by: Unable to resolve 38.0: missing requirement package; (package=javax.security.auth)])

      ERROR: Bundle org.apache.karaf.management Error starting mvn:org.apache.karaf/org.apache.karaf.management/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.management : Unable to resolve 37.0: missing requirement package; (package=javax.management))

      ERROR: Bundle org.apache.karaf.shell.console Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.console/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.console : Unable to resolve 38.0: missing requirement package; (package=javax.security.auth))

      ERROR: Bundle org.apache.karaf.shell.packages Error starting mvn:org.apache.karaf.shell/org.apache.karaf.shell.packages/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.shell.packages : Unable to resolve 39.0: missing requirement package; (&(package=org.apache.felix.gogo.commands)(version>=0.6.0)(!(version>=1.0.0))) [caused by: Unable to resolve 38.0: missing requirement package; (package=javax.security.auth)])

      ERROR: Bundle org.apache.mina.core Error starting mvn:org.apache.mina/mina-core/2.0.1 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.mina.core : Unable to resolve 40.0: missing requirement package; (package=javax.crypto))

      ERROR: Bundle org.apache.karaf.features.core Error starting mvn:org.apache.karaf.features/org.apache.karaf.features.core/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.features.core : Unable to resolve 41.0: missing requirement package; (package=javax.management))

      ERROR: Bundle org.apache.karaf.deployer.blueprint Error starting mvn:org.apache.karaf.deployer/org.apache.karaf.deployer.blueprint/2.2.0-fuse-00-43 (org.osgi.framework.BundleException: Unresolved constraint in bundle org.apache.karaf.deployer.blueprint : Unable to resolve 42.0: missing requirement package; (package=javax.xml.parsers))