0 Replies Latest reply on Sep 8, 2014 10:02 AM by Fredrik Bodin

    XA recovery disabled for ActiveMQXAConnectionFactory

    Fredrik Bodin Newbie

      Hi


      I have followed the instructions for the ActiveMQ JCA adapter configuration.https://developer.jboss.org/wiki/HowToUseOutOfProcessActiveMQWithWildFly

      There is no problem send/receiving msg with the example project!

       

      But I am receiving two  WARN msg in the log file...

      So my questions is how I can solve that.

      ---
      2014-09-08 15:09:34,805 WARN  [org.jboss.as.connector.deployers.RADeployer] (MSC service thread 1-1) IJ020017: Invalid archive: file:/opt/wildfly/modules/system/layers/base/org/apache/activemq/ra/main/./

      2014-09-08 15:09:35,139 WARN  [org.jboss.as.connector.deployers.RaXmlDeployer] (MSC service thread 1-1) IJ020016: Missing <recovery> element. XA recovery disabled for: java:jboss/activemq/ActiveMQXAConnectionFactory

       

      My resource adapter config, where I have included the <recovery> element.

      ---
      <resource-adapter id="activemq-rar.rar">

          <module slot="main" id="org.apache.activemq.ra"/>

          <transaction-support>XATransaction</transaction-support>

          <config-property name="ServerUrl">

              tcp://164.135.40.53:61616

          </config-property>

          <connection-definitions>

              <connection-definition class-name="org.apache.activemq.ra.ActiveMQManagedConnectionFactory" jndi-name="java:jboss/activemq/ActiveMQXAConnectionFactory" enabled="true" use-java-context="true" pool-name="AMQConnectionFactoryXA">

                  <xa-pool>

                      <min-pool-size>0</min-pool-size>

                      <max-pool-size>20</max-pool-size>

                      <prefill>false</prefill>

                      <is-same-rm-override>false</is-same-rm-override>

                  </xa-pool>

                  <recovery no-recovery="false">

                      <recover-plugin class-name="org.jboss.jca.core.recovery.DefaultRecoveryPlugin"/>

                  </recovery>

              </connection-definition>

          </connection-definitions>

          <admin-objects>

              <admin-object class-name="org.apache.activemq.command.ActiveMQQueue" jndi-name="java:/queue/HELLOWORLDMDBQueue" use-java-context="true" pool-name="HELLOWORLDMDBQueue">

                  <config-property name="PhysicalName">

                      HELLOWORLDMDBQueue

                  </config-property>

              </admin-object>

              <admin-object class-name="org.apache.activemq.command.ActiveMQTopic" jndi-name="java:/topic/HELLOWORLDMDBTopic" use-java-context="true" pool-name="HELLOWORLDMDBTopic">

                  <config-property name="PhysicalName">

                      HELLOWORLDMDBTopic

                  </config-property>

              </admin-object>

          </admin-objects>

      </resource-adapter>

      My resource adapter config, where I have included the <recovery> element.

      ---
      <resource-adapter id="activemq-rar.rar">

          <module slot="main" id="org.apache.activemq.ra"/>

          <transaction-support>XATransaction</transaction-support>

          <config-property name="ServerUrl">

              tcp://164.135.40.53:61616

          </config-property>

          <connection-definitions>

              <connection-definition class-name="org.apache.activemq.ra.ActiveMQManagedConnectionFactory" jndi-name="java:jboss/activemq/ActiveMQXAConnectionFactory" enabled="true" use-java-context="true" pool-name="AMQConnectionFactoryXA">

                  <xa-pool>

                      <min-pool-size>0</min-pool-size>

                      <max-pool-size>20</max-pool-size>

                      <prefill>false</prefill>

                      <is-same-rm-override>false</is-same-rm-override>

                  </xa-pool>

                  <recovery no-recovery="false">

                      <recover-plugin class-name="org.jboss.jca.core.recovery.DefaultRecoveryPlugin"/>

                  </recovery>

              </connection-definition>

          </connection-definitions>

          <admin-objects>

              <admin-object class-name="org.apache.activemq.command.ActiveMQQueue" jndi-name="java:/queue/HELLOWORLDMDBQueue" use-java-context="true" pool-name="HELLOWORLDMDBQueue">

                  <config-property name="PhysicalName">

                      HELLOWORLDMDBQueue

                  </config-property>

              </admin-object>

              <admin-object class-name="org.apache.activemq.command.ActiveMQTopic" jndi-name="java:/topic/HELLOWORLDMDBTopic" use-java-context="true" pool-name="HELLOWORLDMDBTopic">

                  <config-property name="PhysicalName">

                      HELLOWORLDMDBTopic

                  </config-property>

              </admin-object>

          </admin-objects>

      </resource-adapter>