1 Reply Latest reply on Mar 11, 2005 5:39 AM by alaveth

    ClassCastException in BMPs after switching from JBoss 3.2.3

    alaveth Newbie

      Hello all,

      I'm running an application on JBoss 3.2.3 with JDK 1.4.2 and an Oracle 8i database, using XDoclet to generate my config files.

      Now I want to move the application to JBoss 3.2.6 for production.

      When I try to access data through an BMP Entity Bean, I get a ClassCastException at the following line:

      OracleResultSet oracleResult = (OracleResultSet) result;


      The same code runs fine in 3.2.3.

      The classes12.jar with the neccessary Oracle classes is present in the lib directory of the server. I've checked the configuration to make sure I didn't overlook anything, but so far I couldn't find anything wrong.

      I searched the JBoss forums and tried Google as well, but thus far I was unable to find anything to help me.

      If anything could point me in the right direction, I'd be really grateful. This is not really a critical matter, since the app runs fine on 3.2.3, but it is bugging me and I'd like to find an answer.

      Thanks a lot,
      Ala

        • 1. Re: ClassCastException in BMPs after switching from JBoss 3.
          alaveth Newbie

          Just some additional information:

          I'm trying to access a CLOB field in my database using the classes from Oracle.

          Any other data (Strings, numerical values) are read just fine, it's only when I try to use the Oracle classes to access the CLOB that I run into an error.

          Because I ran into some problems concerning transactions, I set up a no-tx-datasource that is used exclusively by my BMPs. Changing this to the other data source that is used by the CMP beans makes no difference, however.