2 Replies Latest reply on Mar 4, 2015 11:51 AM by Abhishek Koneru

    Cannot fab:start in JBoss Fuse

    Anthony Roberts Newbie

      My route is complete in the JBoss Developer Studio - I can maven install and then "Run as Local Camel Context" and my route works perfect.

       

      I'm now trying to get this to work without the IDE but getting errors:

       

      root> osgi:install fab:mvn:com.mycompany/camel-blueprint/1.0.0-SNAPSHOT

      Bundle ID: 276

       

      root> fab:start

      Error executing cmomand: Could not find artifact com.mycompany:camel-blueprint:bundle:1.0.0-SNAPSHOT in repos0 (http://repo2.maven.org/maven2)

       

      When I maven build: -Dmaven.test.skip=true install

       

      [INFO] Scanning for projects...

      [INFO]

      [INFO] Using the builder org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder with a thread count of 1

      [INFO]                                                                        

      [INFO] ------------------------------------------------------------------------

      [INFO] Building A Camel Blueprint Route 1.0.0-SNAPSHOT

      [INFO] ------------------------------------------------------------------------

      [INFO]

      [INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ camel-blueprint ---

      [INFO] Using 'UTF-8' encoding to copy filtered resources.

      [INFO] Copying 2 resources

      [INFO]

      [INFO] --- maven-compiler-plugin:2.5.1:compile (default-compile) @ camel-blueprint ---

      [INFO] Nothing to compile - all classes are up to date

      [INFO]

      [INFO] --- maven-resources-plugin:2.6:testResources (default-testResources) @ camel-blueprint ---

      [INFO] Not copying test resources

      [INFO]

      [INFO] --- maven-compiler-plugin:2.5.1:testCompile (default-testCompile) @ camel-blueprint ---

      [INFO] Not compiling test sources

      [INFO]

      [INFO] --- maven-surefire-plugin:2.18.1:test (default-test) @ camel-blueprint ---

      [INFO] Tests are skipped.

      [INFO]

      [INFO] --- maven-bundle-plugin:2.3.7:bundle (default-bundle) @ camel-blueprint ---

      [WARNING] Bundle com.mycompany:camel-blueprint:bundle:1.0.0-SNAPSHOT : Instructions in Private-Package, or -testpackages that are never used: com\.mycompany\.camel\.blueprint\..*|com\.mycompany\.camel\.blueprint

      Classpath: Jar:.,Jar:camel-exec,Jar:commons-exec,Jar:commons-io,Jar:commons-lang,Jar:jaxb-impl,Jar:jaxb-core,Jar:jaxb-api,Jar:istack-commons-runtime,Jar:FastInfoset,Jar:jsr173_api,Jar:camel-core,Jar:camel-blueprint,Jar:camel-core-xml,Jar:camel-core-osgi,Jar:slf4j-api,Jar:slf4j-log4j12,Jar:jcl-over-slf4j,Jar:log4j

       

      [INFO]

      [INFO] --- maven-install-plugin:2.5.2:install (default-install) @ camel-blueprint ---

      [INFO] Installing /home/fusedeveloper/workspace/SMTPManagedService/target/camel-blueprint-1.0.0-SNAPSHOT.jar to /home/fusedeveloper/.m2/repository/com/mycompany/camel-blueprint/1.0.0-SNAPSHOT/camel-blueprint-1.0.0-SNAPSHOT.jar

      [INFO] Installing /home/fusedeveloper/workspace/SMTPManagedService/pom.xml to /home/fusedeveloper/.m2/repository/com/mycompany/camel-blueprint/1.0.0-SNAPSHOT/camel-blueprint-1.0.0-SNAPSHOT.pom

      [INFO]

      [INFO] --- maven-bundle-plugin:2.3.7:install (default-install) @ camel-blueprint ---

      [INFO] Installing com/mycompany/camel-blueprint/1.0.0-SNAPSHOT/camel-blueprint-1.0.0-SNAPSHOT.jar

      [INFO] Writing OBR metadata

      [INFO] ------------------------------------------------------------------------

      [INFO] BUILD SUCCESS

      [INFO] ------------------------------------------------------------------------

      [INFO] Total time: 2.373 s

      [INFO] Finished at: 2015-02-12T17:51:39+10:00

      [INFO] Final Memory: 15M/127M

      [INFO] ------------------------------------------------------------------------

       

      My pom.xml file

       

      <?xml version="1.0" encoding="UTF-8"?>

      <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">

       

        <modelVersion>4.0.0</modelVersion>

       

        <groupId>com.mycompany</groupId>

        <artifactId>camel-blueprint</artifactId>

        <packaging>bundle</packaging>

        <version>1.0.0-SNAPSHOT</version>

       

        <name>A Camel Blueprint Route</name>

        <url>http://www.myorganization.org</url>

       

        <properties>

          <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>

          <project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>

        </properties>

       

        <dependencies>

       

        <dependency>

        <groupId>org.apache.camel</groupId>

        <artifactId>camel-exec</artifactId>

        <version>2.14.0</version>

        </dependency>

       

          <dependency>

            <groupId>org.apache.camel</groupId>

            <artifactId>camel-core</artifactId>

            <version>2.14.0</version>

          </dependency>

          <dependency>

            <groupId>org.apache.camel</groupId>

            <artifactId>camel-blueprint</artifactId>

            <version>2.14.0</version>

          </dependency>

       

          <!-- logging -->

          <dependency>

            <groupId>org.slf4j</groupId>

            <artifactId>slf4j-api</artifactId>

            <version>1.7.7</version>

          </dependency>

          <dependency>

            <groupId>org.slf4j</groupId>

            <artifactId>slf4j-log4j12</artifactId>

            <version>1.7.7</version>

          </dependency>

          <dependency>

            <groupId>org.slf4j</groupId>

            <artifactId>jcl-over-slf4j</artifactId>

            <version>1.7.7</version>

          </dependency>

          <dependency>

            <groupId>log4j</groupId>

            <artifactId>log4j</artifactId>

            <version>1.2.17</version>

          </dependency>

       

          <!-- testing -->

          <dependency>

            <groupId>org.apache.camel</groupId>

            <artifactId>camel-test-blueprint</artifactId>

            <version>2.14.0</version>

            <scope>test</scope>

          </dependency>

        </dependencies>

       

        <build>

          <defaultGoal>install</defaultGoal>

       

          <plugins>

            <plugin>

              <groupId>org.apache.maven.plugins</groupId>

              <artifactId>maven-compiler-plugin</artifactId>

              <version>2.5.1</version>

              <configuration>

                <source>1.6</source>

                <target>1.6</target>

              </configuration>

            </plugin>

            <plugin>

              <groupId>org.apache.maven.plugins</groupId>

              <artifactId>maven-resources-plugin</artifactId>

              <version>2.6</version>

              <configuration>

                <encoding>UTF-8</encoding>

              </configuration>

            </plugin>

       

            <!-- to generate the MANIFEST-FILE of the bundle -->

            <plugin>

              <groupId>org.apache.felix</groupId>

              <artifactId>maven-bundle-plugin</artifactId>

              <version>2.3.7</version>

              <extensions>true</extensions>

              <configuration>

                <instructions>

                  <Bundle-SymbolicName>camel-blueprint</Bundle-SymbolicName>

                  <Private-Package>com.mycompany.camel.blueprint.*</Private-Package>

                  <Import-Package>*</Import-Package>

                </instructions>

              </configuration>

            </plugin>

       

             <!-- to run the example using mvn camel:run -->

            <plugin>

              <groupId>org.apache.camel</groupId>

              <artifactId>camel-maven-plugin</artifactId>

              <version>2.14.0</version>

              <configuration>

                <useBlueprint>true</useBlueprint>

              </configuration>

            </plugin>

       

          </plugins>

        </build>

       

      </project>

       

       

      Any help greatly appreciated!