1 Reply Latest reply on Apr 9, 2015 5:09 PM by Francesco Marchioni

    MavenUtils not found by io.fabric8

    Mylos Kathos Master

      Hi all!

      I'm running JBoss Fuse 6.1 and trying to assign the quickstarts-java-camel.spring to my Fabric Container. This profile is part of the fabric 8 quickstart camel-spring example.

      When I assign the profile to the container the following exception is raised:

      io.fabric8.agent.utils.MultiException: Error while downloading artifacts

        at io.fabric8.agent.utils.AgentUtils$ArtifactDownloader.await(AgentUtils.java:314)

        at io.fabric8.agent.DeploymentBuilder.download(DeploymentBuilder.java:160)

      . . ..

      java.lang.NoClassDefFoundError: io/fabric8/maven/util/MavenUtils

        at io.fabric8.fab.MavenRepositorySystemSession.(MavenRepositorySystemSession.java:61)

      . . .

      Caused by: java.lang.ClassNotFoundException: io.fabric8.maven.util.MavenUtils not found by io.fabric8.fabric-agent 

        at org.apache.felix.framework.BundleWiringImpl.findClassOrResourceByDelegation(BundleWiringImpl.java:1532)

        at org.apache.felix.framework.BundleWiringImpl.access$400(BundleWiringImpl.java:75)

        at org.apache.felix.framework.BundleWiringImpl$BundleClassLoader.loadClass(BundleWiringImpl.java:1955)

        at java.lang.ClassLoader.loadClass(ClassLoader.java:358)

      Here is the build section of the pom.xml:

        <build>
          <defaultGoal>install</defaultGoal>
      
      
          <plugins>
            <plugin>
              <groupId>org.apache.maven.plugins</groupId>
              <artifactId>maven-compiler-plugin</artifactId>
              <configuration>
                <source>${maven.compiler.source}</source>
                <target>${maven.compiler.target}</target>
              </configuration>
            </plugin>
      
      
            <plugin>
              <groupId>org.apache.maven.plugins</groupId>
              <artifactId>maven-resources-plugin</artifactId>
            </plugin>
      
            <plugin>
              <groupId>io.fabric8</groupId>
              <artifactId>fabric8-maven-plugin</artifactId>
              <version>${fabric.version}</version>
            </plugin>
      
            <plugin>
              <groupId>org.apache.camel</groupId>
              <artifactId>camel-maven-plugin</artifactId>
              <version>${camel-version}</version>
            </plugin>
          </plugins>
        </build>
      

      I've seen several posts about this issue and tried also changing the plugin to be used for deploy. Without luck.

      Any idea how to fix it ?