0 Replies Latest reply on Dec 9, 2015 7:24 AM by kavi prabha

    idle connection not get clear

    kavi prabha Newbie

      We are using application server jboss7.1 version,with DB2 AS400 V6R1, (jt400.jar driver)the connection in the connection pool not get clear even set the (<idle-timeout-minutes>1</idle-timeout-minutes> ) idle-timeout-minutes property.

      Below is the Datasource used.

       

      <datasources>  

                                   <datasource jta="true" jndi-name="java:/jdbc/DEPWBDS" pool-name="DEPWBDS" enabled="true" use-ccm="false">           

              <connection-url>jdbc:as400://<ip>:50001/OASISDEP;packageCCSID=13488</connection-url>

                         <datasourceclass>com.ibm.as400.access.AS400JDBCDataSource</datasource-class>                  

      <driver>jt400.jar</driver>

                         <pool>

                             <min-pool-size>1</min-pool-size>   

                          <max-pool-size>2</max-pool-size>            

             </pool>        

                 <security>        

                     <user-name>******</user-name>                                 <password>******</password>    

                     </security>    

                     <validation>               

              <validate-on-match>false</validate-on-match>         

                    <background-validation>false</background-validation>                    </validation>      

                   <timeout>   

                          <idle-timeout-minutes>1</idle-timeout-minutes>                    </timeout>  

                       <statement>        

                     <share-prepared-statements>false</share-prepared-statements>        

                 </statement>          

           </datasource>

      Please help us in resolving this issue.

      Thanks,

      S.kaviprabha.