5 Replies Latest reply on May 4, 2016 6:11 AM by Sony Joseph

    MDB - listening to Active MQ Q - max-delivery attempts

    Sony Joseph Novice

      Hello,

       

      platform JBoss EAP 6.3 full-profile.

      MDB / EJB 3.1

      Destination Messaging system : Active MQ

       

      I am looking for a way to have a control on max-delivery-attempts, useDLQ etc in this scenarion with some configuration changes.

       

      any help on this topic would be helpful

       

      thanks

        • 1. Re: MDB - listening to Active MQ Q - max-delivery attempts
          Miroslav Novak Master

          This is configured in messaging subsystem in:

                          <address-settings>
                              <address-setting match="#">
                                  ...
                                  <max-delivery-attempts>200</max-delivery-attempts>
                                  ...
                                  <dead-letter-address>jms.queue.DLQ</dead-letter-address>
                                  ...
                              </address-setting>
                          </address-settings>
          

           

          Cheers,

          Mirek

          • 2. Re: MDB - listening to Active MQ Q - max-delivery attempts
            Sony Joseph Novice

            Hi Miroslav,

             

            thanks for the reply. In my case the Active MQ is not a subsystem, it is just a stand-alone system independent to EAP. Anyways, I have got it managed by editing the activemq.xml file as below.

             

            <destinationPolicy>

                        <policyMap>

                          <policyEntries>

                            <policyEntry topic=">" producerFlowControl="true">

                              <pendingMessageLimitStrategy>

                                <constantPendingMessageLimitStrategy limit="1000"/>

                              </pendingMessageLimitStrategy>

              </policyEntry>

                            <policyEntry queue=">" producerFlowControl="true" memoryLimit="1mb">

              <deadLetterStrategy>

              <individualDeadLetterStrategy queuePrefix="DLQ." useQueueForQueueMessages="true"/>

               </deadLetterStrategy>

                            </policyEntry>

               </policyEntries>

                        </policyMap>

                    </destinationPolicy>

            • 3. Re: MDB - listening to Active MQ Q - max-delivery attempts
              Miroslav Novak Master

              I can see it now. Sorry for misleading.

              • 4. Re: MDB - listening to Active MQ Q - max-delivery attempts
                Sony Joseph Novice

                Dear Miroslav,

                 

                I am so happy and grateful that you have replied to my problem query. And your reply helps me thinking as to 'why cann't I keep AMQ as a Subsystem'

                 

                thanks

                Sony

                • 5. Re: MDB - listening to Active MQ Q - max-delivery attempts
                  Sony Joseph Novice

                  I wanted to give the correct answer and mark this item closed.

                   

                  To ensure that the delivery of a message on a rollbackonly option I did the below successfully.

                   

                  <resource-adapters>

                                  <resource-adapter id="activemq-ra.rar">

                                      <archive>

                                          activemq-rar.rar

                                      </archive>

                                      <transaction-support>XATransaction</transaction-support>

                                      <config-property name="RedeliveryUseExponentialBackOff">

                                          true

                                      </config-property>

                                      <config-property name="InitialRedeliveryDelay">

                                          2000

                                      </config-property>

                                      <config-property name="MaximumRedeliveries">

                                          3

                                      </config-property>

                                      <config-property name="Password">

                                          admin

                                      </config-property>

                                      <config-property name="RedeliveryBackOffMultiplier">

                                          2

                                      </config-property>

                                      <config-property name="UserName">

                                          admin

                                      </config-property>

                                      <config-property name="ServerUrl">

                  1 of 1 people found this helpful