0 Replies Latest reply on May 11, 2016 8:20 AM by Krishna Kalesh Balakrishnan

    infinispan-server-8.2.1.Final - Server Management Console not showing up data in Cache containers tab when tried with hotrod connector alone

    Krishna Kalesh Balakrishnan Newbie

      I was trying out infinispan-server-8.2.1.Final in domain mode. My requirement is to use only hotrod-connector, so thought of removing memcached-connector, rest-connector, websocket-connector.

       

      Enabling all connectors

      =================

                  <subsystem xmlns="urn:infinispan:server:core:8.2" default-cache-container="clustered">

                      <cache-container name="clustered" default-cache="default" statistics="true">

                          <transport lock-timeout="60000"/>                   

                          <distributed-cache name="default" mode="SYNC" segments="20" owners="2" remote-timeout="30000" start="EAGER">

                              <locking acquire-timeout="30000" concurrency-level="1000" striping="false"/>

                              <transaction mode="NONE"/>

                          </distributed-cache>

                          <distributed-cache name="memcachedCache" mode="SYNC" segments="20" owners="2" remote-timeout="30000" start="EAGER">

                              <locking acquire-timeout="30000" concurrency-level="1000" striping="false"/>

                              <transaction mode="NONE"/>

                          </distributed-cache>

                      </cache-container>

                  </subsystem>

                  <subsystem xmlns="urn:infinispan:server:endpoint:8.0">

                      <hotrod-connector socket-binding="hotrod" cache-container="clustered">

                          <topology-state-transfer lazy-retrieval="false" lock-timeout="1000" replication-timeout="5000"/>

                      </hotrod-connector> 

                      <memcached-connector socket-binding="memcached" cache-container="clustered"/>

                      <rest-connector socket-binding="rest" cache-container="clustered" security-domain="other" auth-method="BASIC"/>

                      <websocket-connector socket-binding="websocket" cache-container="clustered"/>

                  </subsystem>

       

      http://localhost:9990/console/index.html#/clusters\

      enabledall.PNG

       

      After removing memcached-connector, rest-connector & websocket-connector,  Server Management Console not showing up data in Cache container view

       

                 <subsystem xmlns="urn:infinispan:server:endpoint:8.0">

                      <hotrod-connector socket-binding="hotrod" cache-container="clustered">

                          <topology-state-transfer lazy-retrieval="false" lock-timeout="1000" replication-timeout="5000"/>

                      </hotrod-connector> <!-- Removed connectors for memcached, rest, websocket -->

                  </subsystem>

       

      Cache container view is blank

      enabledhot.PNG

       

      While cluster page shows up

      clustterpage.PNG

       

      Cache is working fine, no exceptions in logs and other pages in management console shows good. Only Cache container  page has issue.