1 Reply Latest reply on May 20, 2016 4:46 PM by James Perkins

    Error deploying Apache DayTrader for JBoss in wildfly-10.1.0.Final-SNAPSHOT

    Alfons Warschburger Newbie

        

        

      I always get an error when deploying DayTrader in my new Wildfly installation with MARIADB 10.1.3 as a database.:

       

      07:12:09,947 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-4) MSC000001: Failed to start service jboss.deployment.unit."daytrader-ejb-2.1.7.jar".FIRST_MODULE_USE: org.jboss.msc.service.StartException in service jboss.deployment.unit."daytrader-ejb-2.1.7.jar".FIRST_MODULE_USE: WFLYSRV0153: Failed to process phase FIRST_MODULE_USE of deployment "daytrader-ejb-2.1.7.jar"

          at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:154)

          at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1948)

          at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1881)

          at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

          at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

          at java.lang.Thread.run(Thread.java:745)

      Caused by: javax.persistence.PersistenceException: WFLYJPA0057: PersistenceProvider 'org.apache.openjpa.persistence.PersistenceProviderImpl' not found

          at org.jboss.as.jpa.processor.PersistenceUnitServiceHandler.lookupProvider(PersistenceUnitServiceHandler.java:1009)

          at org.jboss.as.jpa.processor.PersistenceUnitServiceHandler.addPuService(PersistenceUnitServiceHandler.java:270)

          at org.jboss.as.jpa.processor.PersistenceUnitServiceHandler.handleJarDeployment(PersistenceUnitServiceHandler.java:163)

          at org.jboss.as.jpa.processor.PersistenceUnitServiceHandler.deploy(PersistenceUnitServiceHandler.java:133)

          at org.jboss.as.jpa.processor.PersistenceBeginInstallProcessor.deploy(PersistenceBeginInstallProcessor.java:52)

          at org.jboss.as.server.deployment.DeploymentUnitPhaseService.start(DeploymentUnitPhaseService.java:147)

       

       

      There is already a module.xml, persistence.xml and standalone.xml configured which is attached to this thread.

      Also I installed Apache open-jpa as a persistent provider.

       

      What went wrong in my environment ? DO i use a wrong version of Daytrader and how can I get the correct version in case this is true.?