1 Reply Latest reply on Sep 26, 2016 8:03 AM by cosmin cosmin

    Wildfly 9.0.1 undertow 2 gzip usage

    cosmin cosmin Newbie

      Hello, I'm not receiving a gzip-ed response from wildfly on my client's side, part of my configuration is attached.

       

      <subsystem xmlns="urn:jboss:domain:undertow:2.0">
        <buffer-cache name="default"/>
        <server name="default-server">
        <http-listener
         name="default"
         socket-binding="http"
         redirect-socket="https"
         max-post-size="209715200"/>
        <https-listener
         name="https"
         socket-binding="https"
         max-post-size="209715200"
         enabled-cipher-suites="SSL_RSA_WITH_RC4_128_SHA, TLS_RSA_WITH_AES_128_CBC_SHA, TLS_DHE_RSA_WITH_AES_128_CBC_SHA, TLS_DHE_DSS_WITH_AES_128_CBC_SHA"
         security-realm="UndertowRealm"/>
        <host name="default-host" alias="localhost">
        <location name="/" handler="welcome-content"/>
        <filter-ref name="server-header"/>
        <filter-ref name="x-powered-by-header"/>
        <filter-ref name="anti-clickjack-header"/>
        <filter-ref name="limit-connections"/>
      <filter-ref name="gzipFilter" predicate="exists['%{o,Content-Type}'] and min-content-size[10] and regex[pattern='(?:text/plain|text/html|text/xml|application/vnd.syncy+xml)(;.*)?', value=%{o,Content-Type}, full-match=true]"/>
        </host>
        </server>
        <servlet-container name="default">
        <jsp-config/>
        <websockets/>
        </servlet-container>
        <handlers>
        <file name="welcome-content" path="${jboss.home.dir}/welcome-content"/>
        </handlers>
        <filters>
        <connection-limit name="limit-connections" max-concurrent-requests="500" queue-size="100"/>
        <response-header name="server-header" header-name="Server" header-value="WildFly/9"/>
        <response-header name="x-powered-by-header" header-name="X-Powered-By" header-value="Undertow/1"/>
      <response-header name="Vary-header" header-name="Vary" header-value="Accept-Encoding"/>
        <response-header name="anti-clickjack-header" header-name="X-Frame-Options" header-value="SAMEORIGIN"/>
      <gzip name="gzipFilter"/>
        </filters>
      </subsystem>
      
      

       

       

       

       

       

      Thank you