3 Replies Latest reply on Jul 18, 2017 9:16 AM by Miroslav Novak

    Generic JMS exception when migrating EJB application from JBoss 4.2 to WildFly 10

    kavitha Gowda Newbie

      Trying to migrate from Jboss 4.2 to wildfly 10  but the deployment is failing with the below exceptions

       

      we have implemented MessageDrivenBean using EJB 2.0 and trying to deploy the same in wildfly

      but the sampleEJB.jar deployement is failing with the below exception

       

       

       

       

      ([("deployment" => "mainapp.ear")]) - failure description: {"WFLYCTL0180: Services with missing/unavailable dependencies" => [

          "jboss.naming.context.java.comp.com.sampleEJB.InitialServiceActionRequestMDB.ValidatorFactory is missing [jboss.naming.context.java.comp.com.sampleEJB.InitialServiceActionRequestMDB]",

          "jboss.deployment.subunit.\"mainapp.ear\".\"commonEjb.jar\".component.ASyncActionExecutor.CREATE is missing [jboss.ra.generic-jms-ra]",

          "jboss.deployment.subunit.\"mainapp.ear\".\"mainapp.war\".INSTALL is missing [jboss.deployment.subunit.\"mainapp.ear\".\"sampleEJB.jar\".deploymentCompleteService]",

          "jboss.deployment.subunit.\"mainapp.ear\".\"sampleEJB.jar\".batch.environment is missing [jboss.deployment.subunit.\"mainapp.ear\".\"sampleEJB.jar\".beanmanager]",

          "jboss.naming.context.java.comp.com.sampleEJB.InitialServiceActionRequestMDB.HandleDelegate is missing [jboss.naming.context.java.comp.com.sampleEJB.InitialServiceActionRequestMDB]",

          "jboss.deployment.subunit.\"mainapp.ear\".\"mainapp.war\".batch.environment is missing [jboss.deployment.subunit.\"mainapp.ear\".\"mainapp.war\".beanmanager]",

          "jboss.naming.context.java.comp.com.sampleEJB.InitialServiceActionRequestMDB.ORB is missing [jboss.naming.context.java.comp.com.sampleEJB.InitialServiceActionRequestMDB]",

          "jboss.naming.context.java.comp.com.sampleEJB.InitialServiceActionRequestMDB.InstanceName is missing [jboss.naming.context.java.comp.com.sampleEJB.InitialServiceActionRequestMDB]",

          "jboss.naming.context.java.comp.com.sampleEJB.InitialServiceActionRequestMDB.InAppClientContainer is missing [jboss.naming.context.java.comp.com.sampleEJB.InitialServiceActionRequestMDB]",

          "jboss.deployment.unit.\"mainapp.ear\".deploymentCompleteService is missing [jboss.deployment.subunit.\"mainapp.ear\".\"mainapp.war\".deploymentCompleteService, jboss.deployment.subunit.\"mainapp.ear\".\"sampleEJB.jar\".deploymentCompleteService]",

          "jboss.naming.context.java.comp.com.sampleEJB.InitialServiceActionRequestMDB.Validator is missing [jboss.naming.context.java.comp.com.sampleEJB.InitialServiceActionRequestMDB]"

       

       

      below is the JMS configuration in standalone.xml file

       

       

      <subsystem xmlns="urn:jboss:domain:resource-adapters:4.0">

                  <resource-adapters>

                      <resource-adapter id="generic-jms-ra.rar">

                          <archive>

                              generic-jms-ra.rar

                          </archive>

                          <transaction-support>XATransaction</transaction-support>

                          <connection-definitions>

                              <connection-definition class-name="org.jboss.resource.adapter.jms.JmsManagedConnectionFactory" jndi-name="JmsXA" pool-name="StdJMSPool">

                                  <config-property name="ConnectionFactory">

                                      java:/XAConnectionFactory

                                  </config-property>

                                  <config-property name="JndiParameters">

                                      java.naming.factory.initial=org.jnp.interfaces.NamingContextFactory;java.naming.provider.url=localhost:1100

                                  </config-property>

                                  <security>

                                      <application/>

                                  </security>

                              </connection-definition>

                          </connection-definitions>

                      </resource-adapter>

                  </resource-adapters>

              </subsystem>

       

       

       

       

      Not sure if i am missing any other configuration , Any help in rectifying these errors will be much appreciated.