3 Replies Latest reply on Sep 9, 2017 9:34 AM by jaikiran pai

    IllegalArgumentException: XNIO001001: No XNIO provider on Windows

    Martin Choma Expert

      I have one windows machine where "XNIO001001: No XNIO provider found" intermittently appears.  Once by starting server

       

      org.jboss.msc.service.StartException in service jboss.serverManagement.controller.management.worker: Failed to start service
      06:51:44     at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1978)
      06:51:44     at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      06:51:44     at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      06:51:44     at java.lang.Thread.run(Thread.java:748)
      06:51:44 Caused by: java.lang.IllegalArgumentException: XNIO001001: No XNIO provider found
      06:51:44     at org.xnio.Xnio.doGetInstance(Xnio.java:261)
      06:51:44     at org.xnio.Xnio.getInstance(Xnio.java:194)
      06:51:44     at org.jboss.as.server.mgmt.ManagementWorkerService.start(ManagementWorkerService.java:51)
      06:51:44     at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:2032)
      06:51:44     at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1955)
      06:51:44     ... 3 more
      06:51:44 
      06:51:44 02:50:47,805 INFO  [org.jboss.as.security] (MSC service thread 1-4) WFLYSEC0001: Current PicketBox version=5.0.2.Final-redhat-1
      06:51:44 02:50:47,810 ERROR [org.jboss.as.controller.management-operation] (ServerService Thread Pool -- 41) WFLYCTL0013: Operation ("add") failed - address: ([
      06:51:44     ("subsystem" => "io"),
      06:51:44     ("worker" => "default")
      06:51:44 ]): java.lang.IllegalArgumentException: XNIO001001: No XNIO provider found
      06:51:44     at org.xnio.Xnio.doGetInstance(Xnio.java:261)
      06:51:44     at org.xnio.Xnio.getInstance(Xnio.java:194)
      06:51:44     at org.wildfly.extension.io.WorkerAdd.performRuntime(WorkerAdd.java:163)
      06:51:44     at org.jboss.as.controller.AbstractAddStepHandler.performRuntime(AbstractAddStepHandler.java:337)
      06:51:44     at org.jboss.as.controller.AbstractAddStepHandler$1.execute(AbstractAddStepHandler.java:151)
      06:51:44     at org.jboss.as.controller.AbstractOperationContext.executeStep(AbstractOperationContext.java:976)
      06:51:44     at org.jboss.as.controller.AbstractOperationContext.processStages(AbstractOperationContext.java:722)
      06:51:44     at org.jboss.as.controller.AbstractOperationContext.executeOperation(AbstractOperationContext.java:446)
      06:51:44     at org.jboss.as.controller.ParallelBootOperationStepHandler$ParallelBootTask.run(ParallelBootOperationStepHandler.java:386)
      06:51:44     at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
      06:51:44     at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
      06:51:44     at java.lang.Thread.run(Thread.java:748)
      06:51:44     at org.jboss.threads.JBossThread.run(JBossThread.java:320)
      

       

      In other case by running jboss-cli.bat

       

      13:35:48,065 INFO  [org.jboss.eapqe.krbldap.utils.CustomCLIExecutor] (main) Command:[W:\workspace\eap-7x-ldap-kerberos-testsuite-AD2012R2-windows\75b14564\tests-ldap-kerberos\eap71/../tests/target/dist/jboss-eap\bin\jboss-cli.bat, -Djboss.cli.config=W:\workspace\eap-7x-ldap-kerberos-testsuite-AD2012R2-windows\75b14564\tests-ldap-kerberos\eap71/../tests/target/dist/jboss-eap\bin\jboss-cli.xml, -c, 
      --controller=remote+http://localhost:9990, --timeout=60000, -Djavax.security.auth.useSubjectCredsOnly=false, -Djava.security.krb5.conf=W:\\workspace\\eap-7x-ldap-kerberos-testsuite-AD2012R2-windows\\75b14564\\tests-ldap-kerberos\\eap71\\target\\krb\\krb5-4286734634242485058.conf, -Dsun.security.krb5.debug=true, -Dcom.ibm.security.jgss.debug=all, -Dcom.ibm.security.krb5.Krb5Debug=all
      , -Dwildfly.config.url=file:///W:/workspace/eap-7x-ldap-kerberos-testsuite-AD2012R2-windows/75b14564/tests-ldap-kerberos/eap71/target/KerberosCLIGs2Krb5PlusTestCase/wildfly-config.xml, --error-on-interact, :whoami]
      13:35:51,666 INFO  [org.jboss.eapqe.krbldap.utils.CustomCLIExecutor] (main) CLI executor output:
      13:35:51,666 INFO  [org.jboss.eapqe.krbldap.utils.CustomCLIExecutor] (main) java.lang.ExceptionInInitializerError: XNIO001001: No XNIO provider found
      

       

      I suspect something is wrong with this machine. Could someone hint what can that be? Could that be too much open ports or too many network handles?