2 Replies Latest reply on Jul 2, 2018 5:13 AM by Martin Choma

    Wildfly 8.2.1 Integration with Spnego

    Nagaraju Chitimilla Newbie

      I'm finding difficulty in integrating the Spnego with the wildfly 8.2.1. I have followed the following steps as of now,l but still its not working.

       

      Below is my project structure:

       

      Application.ear

      ├───META-INF

      │       application.xml

      │       jboss-app.xml

      │       jboss-deployment-structure.xml

      Application.war

      │   └───WEB-INF

      │       │   jboss-web.xml

      │       │   web.xml

       

      standalone-full.xml:

      <system-properties>

              <property name="sun.security.krb5.debug" value="true"/>

              <property name="java.security.krb5.kdc" value="hostname.domain.com"/>

              <property name="java.security.krb5.realm" value="domain.COM"/>

              <property name="java.security.krb5.conf" value="C:\wildfly-8.2.1.Final\bin\krb5.conf"/>

      <property name="jboss.security.disable.secdomain.option" value="true"/>

          </system-properties>

       

      <security-domain name="host" cache-type="default">

           <authentication>

                <login-module code="Kerberos" flag="required">

                     <module-option name="debug" value="true"/>

                     <module-option name="storeKey" value="true"/>

                     <module-option name="refreshKrb5Config" value="true"/>

                     <module-option name="useKeyTab" value="true"/>

                     <module-option name="doNotPrompt" value="true"/>

                     <module-option name="keyTab"         value="C:/wildfly-8.2.1.Final/standalone/configuration/server.keytab"/>

                     <module-option name="principal"         value="HTTP/hostname.domain.com@domain.COM"/>

                </login-module>

           </authentication>

      </security-domain>

       

       

      <security-domain name="SPNEGO" cache-type="default">

           <authentication>    

                <login-module code="SPNEGO" flag="required">      

                     <module-option name="password-stacking" value="useFirstPass"/>

                     <module-option name="serverSecurityDomain"         value="host"/>    

                </login-module>  

           </authentication>  

      </security-domain>

       

       

      jboss-web.xml

      <jboss-web>

          <security-domain>SPNEGO</security-domain> <valve>         <class-name>org.jboss.security.negotiation.NegotiationAuthenticator</class-name> </valve>

      </jboss-web>

       

      jboss-deployment-structure.xml

      <?xml version="1.0" encoding="UTF-8"?>

      <jboss-deployment-structure>

           <deployment>

                <dependencies>

                     <module name="org.jboss.security.negotiation"/>

                </dependencies>

           </deployment>

      </jboss-deployment-structure>

       

      Did i missed any other configurations?

       

      Thanks in advance!