3 Replies Latest reply on Jan 2, 2019 8:29 AM by Christoph John

    Howto Configure Teiid Wildfly to use Odata V2 protocol version instead of V4

    Christoph John Novice

      Hello together,

      I think the topic says already everything. I am currently using Teiid 9 and Teiid 11.2 Wildfly. Both by default use OData V4 Protocol. As I am currently working with a client side odata library for which OData V4 is highly experimental, I am trying to configure Teiid to speak OData V2 instead. So far I have not found a config option or description on how to achieve this. I am even not sure if I can expect an config option. Might it be that I have to replace

       

      teiid-olingo-odata4.war

       

      with something like teiid-olingo-odata2.war

       

      In that case, where can I find the required war file ? Every help is welcome. Thanks a lot and happy new year

       

      Best regards,

      Christoph