2 Replies Latest reply on May 20, 2003 12:23 AM by nboz

    jbosscmp-jdbc.xml not working?

    nboz Newbie

      Hi

      I have JBoss 3.2.1 installed and trying to get my EJB's to use other database than DefaultDS ( which is configured to use Hypersonic ). I have edited standardjbosscmp-jdbc.xml and made my own file in META-INF/jbosscmp-jdbc.xml. My datasource is tested and working ( application also supports "direct" sql connections ).
      Secondly I really dont know where is the default cmp ds configured coz when I edited the standardjbosscmp-jdbc.xml, changed create table -> false, it still tries to create those tables to HSSQL. Why?

      So, could someone point me the right directory/file?

      Thnx.

      .nboz

        • 1. Re: jbosscmp-jdbc.xml not working?
          nboz Newbie

          Replying to myself.
          Renamed jbosscmp-jdbc.xml -> jaws.xml. Made changes to match jaws specs. It worked. Why? Don't know, I was in believe that jaws.xml is not used anymore and jbosscmp-jdbc.xml file is the "standard" definition file.

          Well, lets get it on.

          .nboz

          • 2. Re: jbosscmp-jdbc.xml not working?
            nboz Newbie

            Replying to myself.
            Renamed jbosscmp-jdbc.xml -> jaws.xml. Made changes to match jaws specs. It worked. Why? Don't know, I was in believe that jaws.xml is not used anymore and jbosscmp-jdbc.xml file is the "standard" definition file.

            Well, lets get it on.

            .nboz