1 Reply Latest reply on Dec 16, 2003 4:29 PM by Adrian Brock

    Stateless Server Beans are not being removed from InstancePo

    tgibson Newbie

      I have modified my stardardjboss.xml but for some reason I cannot get the StatelessSessionInstancePool to shrink down to the minimum size(2)

      Current Size: 5


      I am using JBoss 3.2.1 with the following in my standardjboss.xml
      <container-configuration>
      <container-name>Standard Stateless SessionBean</container-name>
      <!-- <call-logging>true</call-logging> TMG -->
      <call-logging>true</call-logging>
      <invoker-proxy-binding-name>stateless-rmi-invoker</invoker-proxy-binding-name>
      <container-interceptors>
      org.jboss.ejb.plugins.ProxyFactoryFinderInterceptor
      org.jboss.ejb.plugins.LogInterceptor
      org.jboss.ejb.plugins.SecurityInterceptor
      <!-- CMT -->
      org.jboss.ejb.plugins.TxInterceptorCMT
      org.jboss.ejb.plugins.MetricsInterceptor
      org.jboss.ejb.plugins.StatelessSessionInstanceInterceptor
      <!-- BMT -->
      org.jboss.ejb.plugins.StatelessSessionInstanceInterceptor
      org.jboss.ejb.plugins.TxInterceptorBMT
      org.jboss.ejb.plugins.MetricsInterceptor
      org.jboss.resource.connectionmanager.CachedConnectionInterceptor
      </container-interceptors>
      <!-- Added my TMG -->
      <container-cache-conf>
      <cache-policy>org.jboss.ejb.plugins.LRUEnterpriseContextCachePolicy</cache-policy>
      <cache-policy-conf>
      <min-capacity>1</min-capacity>
      <max-capacity>20</max-capacity>
      <!-- CONTROL REMOVAL -->
      <remover-period>10</remover-period>
      <max-bean-life>10</max-bean-life>
      <!-- CONTROL PASSIVATION -->
      <overager-period>15</overager-period>
      <max-bean-age>30</max-bean-age>
      <max-cache-miss-period>3</max-cache-miss-period>
      <min-cache-miss-period>1</min-cache-miss-period>
      <cache-load-factor>0.75</cache-load-factor>
      </cache-policy-conf>
      </container-cache-conf>
      <!-- -->
      <instance-pool>org.jboss.ejb.plugins.StatelessSessionInstancePool</instance-pool>
      <instance-cache></instance-cache>
      <persistence-manager></persistence-manager>
      <container-pool-conf>
      <!-- CONTROL REMOVAL -->
      <remover-period>10</remover-period>
      <max-bean-life>10</max-bean-life>
      <!-- CONTROL PASSIVATION -->
      <overager-period>15</overager-period>
      <max-bean-age>30</max-bean-age>
      2
      true
      25
      30
      </container-pool-conf>
      </container-configuration>


      I have search through this forums all day and I have been unable to find anything. All my settings seem to be ignored.

      I would like to define an instance pool with a min size of 2 and a max size of 25 and after 30 seconds those instances removed from pool and destroyed.



      Regards,
      Travis
      http://www/travismgibson.com