2 Replies Latest reply on Sep 1, 2004 5:16 PM by Anton Bauer

    TibcoEMS/EJB example in JBOSS

    Anton Bauer Newbie

      Hi!

      I try to deploy an TibcoEMS/EJB example in JBOSS.
      I used the guide "JBoss JMS provider for WebSphere MQ"
      With "myTest" connector I can access to tibjmsd.exe, but in JBOSS I get this STACK:

      **************************************************************
      09:30:33,656 INFO [Server] Server Home Dir: E:\jboss-4.0.0RC1\server\TibcoConfi
      g
      09:30:33,656 INFO [Server] Server Home URL: file:/E:/jboss-4.0.0RC1/server/Tibc
      oConfig/
      09:30:33,656 INFO [Server] Server Data Dir: E:\jboss-4.0.0RC1\server\TibcoConfi
      g\data
      09:30:33,687 INFO [Server] Server Temp Dir: E:\jboss-4.0.0RC1\server\TibcoConfi
      g\tmp
      09:30:33,687 INFO [Server] Server Config URL: file:/E:/jboss-4.0.0RC1/server/Ti
      bcoConfig/conf/
      09:30:33,687 INFO [Server] Server Library URL: file:/E:/jboss-4.0.0RC1/server/T
      ibcoConfig/lib/
      09:30:33,687 INFO [Server] Root Deployment Filename: jboss-service.xml
      09:30:33,703 INFO [Server] Starting General Purpose Architecture (GPA)...
      09:30:34,968 INFO [ServerInfo] Java version: 1.4.0,Sun Microsystems Inc.
      09:30:34,984 INFO [ServerInfo] Java VM: Java HotSpot(TM) Client VM 1.4.0-b92,Su
      n Microsystems Inc.
      09:30:34,984 INFO [ServerInfo] OS-System: Windows NT 4.0,x86
      09:30:36,000 INFO [Server] Core system initialized
      09:30:46,328 INFO [Log4jService$URLWatchTimerTask] Configuring from URL: resour
      ce:log4j.xml
      09:30:47,578 INFO [WebService] Using RMI server codebase: http://pcb912:8083/
      09:30:47,875 INFO [NamingService] Started jnpPort=1099, rmiPort=1098, backlog=5
      0, bindAddress=null, Client SocketFactory=null, Server SocketFactory=null
      09:31:16,781 WARN [ServiceController] Problem starting service jmx.service.tibj
      ms:service=TibjmsTopicConnectionFactory
      java.lang.NoClassDefFoundError: javax/jms/JMSException
      at jmx.service.tibjms.SXConnectionFactory.createObject(SXConnectionFacto
      ry.java:40)
      at jmx.service.jndi.JNDI.start(JNDI.java:54)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatch
      er.java:141)
      at org.jboss.mx.server.Invocation.dispatch(Invocation.java:80)
      at org.jboss.mx.server.Invocation.invoke(Invocation.java:72)
      at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.
      java:230)
      at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:642)
      at org.jboss.system.ServiceController$ServiceProxy.invoke(ServiceControl
      ler.java:861)
      at $Proxy18.start(Unknown Source)
      at org.jboss.system.ServiceController.start(ServiceController.java:369)
      at sun.reflect.GeneratedMethodAccessor8.invoke(Unknown Source)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      ****************************************************************

      TibjmsTopicConnectionFactory is only the reference used in tibco.

      Problem: I never use JMSException !!!

      I tried the set classpath, STACK again
      I tried to deploy JMSException.class with myTest

      Have anyone experience in JBOSS?