4 Replies Latest reply on May 5, 2005 9:15 AM by alex pollo

    ebxml vs. UDDI

    alex pollo Newbie

      Hi,
      I want to access a UDDI server from within jboss. I have set the "ShouldBindJaxr" property in:

      C:\jboss-4.0.1sp1\server\all\deploy\ebxmlrr-service.sar\META-INF\jboss-service.xml

      I lookup the server and find the "ConnectionFactory" of type:

      com.sun.xml.registry.ebxml.ConnectionFactoryImpl,

      but I want a ConnectionFactory of type:

      com.sun.xml.registry.uddi.ConnectionFactoryImpl.

      Is there a way to retrieve a connectionfactory of this type?

      Thanks in advance,
      Alex

        • 1. Re: ebxml vs. UDDI
          Anil Saldanha Master

          Alex, jboss4-0-1sp1 includes an ebxml registry. If you would like to use uddi, you need to wait for jboss 4.0.2 (to be released within a week). If not get the release candidates for jboss 4.0.2

          • 2. Re: ebxml vs. UDDI
            alex pollo Newbie

            Thank you very much for your answer! (but I've another problem)

            I've downloaded the JBOSS AS 4.0.2. I lookup the connectionfactory.

            That's ok. Now I've to access a registry server (from a stateful

            sesssion bean) that is on another machine say at yyy.yyy.yyy.yyy

            (jboss runs on xxx.xxx.xxx.xxx). The registry server is not jUddi

            but the Sun's RegistryServer that comes with jwsdp-1.5.

            How could I perform this? (Are there some properties to set?)


            Thanks in advance.

            Alex

            • 3. Re: ebxml vs. UDDI
              Anil Saldanha Master

               

              <sysproperty key="javax.xml.registry.ConnectionFactoryClass"
               value="org.apache.ws.scout.registry.ConnectionFactoryImpl"/>
              


              Try to pass in a system property that has the ConnectionFactory of the Sun's Jaxr implementation provided in jwsdp 1.5

              • 4. Re: ebxml vs. UDDI
                alex pollo Newbie

                Great!!!

                I used factoryClass instead of ConnectionFactoryClass. This was the
                mistake!

                Thank you very much!

                Alex