0 Replies Latest reply on Aug 16, 2001 10:41 AM by kanjar

    servlet forwarding error

    kanjar Newbie

      I have deployed a web application including data acces ejb, business logic ejb and servlets to jboss+tomcat. This application worked fine with bea weblogic 5.1, but now i'm facing a problem...

      My main servlet has to forward a servlet named ia. For that i wrote the following code in the doGet method:

      RequestDispatcher rd= getServletContext().getRequestDispatcher("/ia");
      rd.forward(req,res);

      When i try to acces the first page, i get a blank page instead. The url i write in my browser is : http://localhost:8080/nsk/servlet/main

      but ia servlet seems to work since i can acces it directly from the browser. And it appears that it is not initialized when it is called from the main servlet...

      structure of my application.ear:
      application-ejb.jar
      application-client.war
      META-INF\application.xml
      META-INF\manifest.mf

      structure of my application-client.war:
      WEB-INF\classes\com....
      WEB-INF\web.xml
      META-INF\manifest.mf

      in the manifest.mf i added the classpath to application-client.jar, assuming it is needed (but i'm not really sure)

      in the web.xml i associated servlet classes full names and container names as usual.

      my system config:
      *win98+internet explorer 5
      *jdk1.3
      *jboss2.2.2-tomcat package + servlet api


      Could anyone help me to overcome my problem?
      thanks. Greg