1 Reply Latest reply on Jul 7, 2003 9:44 AM by sector

    Unable to Compile JSP at jboss-4.0.0DR1_tomcat-4.1.24

    jboss1604 Newbie

      hi
      i just downloaded the jboss latest Developer version jboss-4.0.0DR1_tomcat-4.1.24 and unzipped to 'd:\jboss-4.0.0DR1_tomcat-4.1.24'.then i configured for oracle at standardjaws.xml,standardjbosscmp-jdbc.xml and Oracle-ds-service.xml.Then i delpoyed my entityBean it has JSP pages for Client use.the server deployed properly and created context path.When i try to call my JSP page, it displayed unable to Compile JSP error messages as follows.here i copied tools.jar to 'tomcat/common/lib'directory only.
      org.apache.jasper.JasperException: Unable to compile class for JSP

      An error occurred at line: -1 in the jsp file: null

      Generated servlet error:
      [javac] Since fork is true, ignoring compiler setting.
      [javac] Compiling 1 source file
      [javac] Since fork is true, ignoring compiler setting.
      [javac] D:\jboss-4.0.0DR1_tomcat-4.1.24\tomcat-4.1.x\work\MainEngine\localhost\LevelMas\levelmaster\LevelMasterView_jsp.java:12: package rtc.ejb.levelmaster does not exist
      [javac] import rtc.ejb.levelmaster.*;


      But the same entityBean runs properly at Jboss3.0-tomcat4.0.i did not configure specific to JSP in Jboss3.0-tomcat4.0.
      Pls do needful

      with regards
      vijay