0 Replies Latest reply on Nov 3, 2003 10:05 AM by ljoncas

    Hot Deploy Error on JBoss3.2.1/Tomcat4.1.24

    ljoncas Newbie

      We are using JBoss 3.2.1 and Tomcat 2.1.24 and everything is working fine, but when we try to do hot deploy during development, lots of exceptions occur and JBoss has to be restarted.

      The ant-based build rebuilds our WAR and copies it to our server deploy directory. JBoss logs an "Undeploying" message and a "Starting deployment" message for our log file and it looks like our app is restarting cleanly. But then a bunch of the servelts generate errors such as

      2003-10-29 15:40:30,717 [ScannerThread] ERROR localhost.Engine - StandardContext[]: Servlet threw load() exception
      javax.servlet.ServletException: Wrapper cannot find servlet class com.paytronix.thecard.pxserver.servlet.web.webui.DownloadPasswordCredentialServlet or a class it depends on
      at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:891)
      at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:823)
      at org.apache.catalina.core.StandardContext.loadOnStartup(StandardContext.java:3420)
      at org.apache.catalina.core.StandardContext.start(StandardContext.java:3608)
      at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:821)
      at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:807)
      at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:579)
      at org.jboss.web.catalina.EmbeddedCatalinaService41.createWebContext(EmbeddedCatalinaService41.java:417)
      at org.jboss.web.catalina.EmbeddedCatalinaService41.performDeploy(EmbeddedCatalinaService41.java:266)
      at org.jboss.web.AbstractWebContainer.start(AbstractWebContainer.java:357)
      at org.jboss.deployment.MainDeployer.start(MainDeployer.java:832)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:640)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:613)
      at java.lang.reflect.Method.invoke(Native Method)
      at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
      at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:549)
      at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:177)
      at $Proxy7.deploy(Unknown Source)
      at org.jboss.deployment.scanner.URLDeploymentScanner.deploy(URLDeploymentScanner.java:302)
      at org.jboss.deployment.scanner.URLDeploymentScanner.scan(URLDeploymentScanner.java:458)
      at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.doScan(AbstractDeploymentScanner.java:200)
      at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.loop(AbstractDeploymentScanner.java:211)
      at org.jboss.deployment.scanner.AbstractDeploymentScanner$ScannerThread.run(AbstractDeploymentScanner.java:190)



      I've looked through the forums and haven't found anything that solves our problem.

      Does Hot Deploy work for JBoss3.2.1/Tomcat4.1.24 in general?

      Any sugggestions about what might be wrong in this case?

      Does Hot Deploy work better for JBoss3.2.2/Tomcat4.1.27?

      And for Tomcat 4.1.27, there is a hot fix for this specific problem that I have reported. Is the Tomcat hot fix already included in the JBoss deployment OR are there any special instructions for applying the hot fix to the JBoss-buyndled Tomcat?


      Thanks

      Leo Joncas