0 Replies Latest reply on May 18, 2005 11:57 PM by Kumaravel Anand

    Problem configuring TassieDB database to work with Tassie On

    Kumaravel Anand Newbie

      Hi everybody
      I have been unable to get Budi Kurniawan's application to read anything from the database TassieDB . I am not sure what is wrong. I downloaded the database from the CD. Then since this was an older version of Access, I had to let my Access convert it to the newer form.

      I then configured the Database the way I thought I should in order for it to work. I created a Data Source Name called TassieDB, by following the procedure to create a System DSN on Windows. I selected the Microsoft Access Driver and associated my Database which I named TassieDB1, which I deposited under C:\budibookstore which also contains the package com.brainysoftware.tassie.servlet.ejb

      When I access the SearchServlet page and type in "Computer" in the search box nothing turns up. I wonder what is going on?

      The following errors are spewed out by Apache in this process:

      May 18, 2005 8:27:24 PM org.apache.coyote.http11.Http11Protocol init
      INFO: Initializing Coyote HTTP/1.1 on http-8080
      Starting service Tomcat-Standalone
      Apache Tomcat/4.1.31
      May 18, 2005 8:27:28 PM org.apache.struts.util.PropertyMessageResources
      INFO: Initializing, config='org.apache.struts.util.LocalStrings', returnNull=tru
      e
      May 18, 2005 8:27:28 PM org.apache.struts.util.PropertyMessageResources
      INFO: Initializing, config='org.apache.struts.action.ActionResources', returnNul
      l=true
      May 18, 2005 8:27:29 PM org.apache.struts.util.PropertyMessageResources
      INFO: Initializing, config='org.apache.webapp.admin.ApplicationResources', retur
      nNull=true
      May 18, 2005 8:27:33 PM org.apache.coyote.http11.Http11Protocol start
      INFO: Starting Coyote HTTP/1.1 on http-8080
      May 18, 2005 8:27:33 PM org.apache.jk.common.ChannelSocket init
      INFO: JK2: ajp13 listening on /0.0.0.0:8009
      May 18, 2005 8:27:33 PM org.apache.jk.server.JkMain start
      INFO: Jk running ID=0 time=10/150 config=C:\tomcatj\conf\jk2.properties
      javax.naming.NoInitialContextException: Cannot instantiate class: org.jnp.interf
      aces.NamingContextFactory [Root exception is java.lang.ClassNotFoundException: o
      rg.jnp.interfaces.NamingContextFactory]
      javax.naming.NoInitialContextException: Cannot instantiate class: org.jnp.interf
      aces.NamingContextFactory [Root exception is java.lang.ClassNotFoundException: o
      rg.jnp.interfaces.NamingContextFactory]


      All help is gratefully acknowledged and accepted. Thanks in advance