3 Replies Latest reply on Dec 13, 2005 3:52 PM by dev per

    tomcat connector for sun one web server 6.1 not working

    dev per Newbie

      Hi ,
      I downloaded tomcat connector for sun one web server and conefigured it it sun one web server 6.1

      I followd the instructions in the
      http://tomcat.apache.org/tomcat-4.1-doc/jk2/howto/nes.html

      when i type a url in the browser sun one web server tries to find it in sun one web server's doc root.

      I have downloaded the nspai_redirect.dll under http://archive.apache.org/dist/tomcat/tomcat-connectors/jk/binaries/win32/

      i am wondering whether this is the right version to use

      appreciate your help in this regard

        • 1. Re: tomcat connector for sun one web server 6.1 not working
          dev per Newbie

          fyi:
          i am using jboss 3.2.5/tomcat 5.0.26 on windows 2000 and sun one web server6.1

          • 2. Re: tomcat connector for sun one web server 6.1 not working
            dev per Newbie

            this what i added in myobj.conf

            NameTrans fn="assign-name" from="/index(|/*)" find-pathinfo-forward="" name="jknsapi"
            NameTrans fn="assign-name" from="*/index/*" find-pathinfo-forward="" name="jknsapi"



            Service fn="jk_service" method="*" worker="worker1"



            i get an error in sun web sever console as

            config: for host 163.185.55.58 trying to GET /index/registration.jsp, func_exec
            reports: HTTP2120: no handler function given for directive


            i think sun web server is not able to find jk_service method.
            But it is able tp find nsapi_redirect.dll .Becuase i see this in nsapi.log

            [Tue Dec 13 13:30:06 2005] [2920:2980] [debug] jk_ajp_common.c (2012): up to 1 endpoints to close
            [Tue Dec 13 13:30:08 2005] [2980:1888] [debug] jk_shm.c (134): Initialized shared memory size=67584 free=65536 addr=0x12deb48
            [Tue Dec 13 13:30:08 2005] [2980:3180] [debug] jk_worker.c (236): creating worker worker1
            [Tue Dec 13 13:30:08 2005] [2980:3180] [debug] jk_worker.c (141): about to create instance worker1 of ajp13
            [Tue Dec 13 13:30:08 2005] [2980:3180] [debug] jk_worker.c (154): about to validate and init worker1
            [Tue Dec 13 13:30:08 2005] [2980:3180] [debug] jk_ajp_common.c (1806): worker worker1 contact is 'localhost:8009'
            [Tue Dec 13 13:30:08 2005] [2980:3180] [debug] jk_ajp_common.c (1895): setting socket keepalive to 0
            [Tue Dec 13 13:30:08 2005] [2980:3180] [debug] jk_ajp_common.c (1934): setting socket timeout to -1
            [Tue Dec 13 13:30:08 2005] [2980:3180] [debug] jk_ajp_common.c (1938): setting socket buffer size to 0
            [Tue Dec 13 13:30:08 2005] [2980:3180] [debug] jk_ajp_common.c (1942): setting connection recycle timeout to 0
            [Tue Dec 13 13:30:08 2005] [2980:3180] [debug] jk_ajp_common.c (1946): setting cache timeout to 0
            [Tue Dec 13 13:30:08 2005] [2980:3180] [debug] jk_ajp_common.c (1950): setting connect timeout to 0
            [Tue Dec 13 13:30:08 2005] [2980:3180] [debug] jk_ajp_common.c (1954): setting reply timeout to 0
            [Tue Dec 13 13:30:08 2005] [2980:3180] [debug] jk_ajp_common.c (1958): setting prepost timeout to 0
            [Tue Dec 13 13:30:08 2005] [2980:3180] [debug] jk_ajp_common.c (1962): setting recovery opts to 0
            [Tue Dec 13 13:30:08 2005] [2980:3180] [debug] jk_ajp_common.c (1966): setting number of retries to 3
            [Tue Dec 13 13:30:08 2005] [2980:3180] [debug] jk_ajp_common.c (1843): setting connection cache size to 1
            [Tue Dec 13 13:30:08 2005] [2980:3180] [debug] jk_worker.c (248): removing old worker1 worker
            [Tue Dec 13 13:30:09 2005] [2980:1888] [debug] jk_nsapi_plugin.c (246): jk_init, a second passed



            • 3. Re: tomcat connector for sun one web server 6.1 not working
              dev per Newbie

              I debugged this problem .
              this is what happens..
              As jk_service is handling the req with some erros or as it aborts the operation the j2ee handler in sun one web serve handles the request.

              Could anybody help me in debugging jk_service.
              there is no log msg for jk_service.
              Could anybody help me pls..