3 Replies Latest reply on Apr 17, 2006 11:29 AM by kelly hays

    myCGI.exe in browser address

    Joni Soares Newbie

      Hi,

      I have a myCGI.exe that works fine with IIS(inserting the URL in the browser address), but when I use it in JBOSS and then it tries to download the file(myCGI.exe) the problem happens: the download is the problem, i don't want to download the file, i want to execute the file and it generates my webfiles.

      where can i set (in JBOSS) to execute my cgi file without making the download when inserting the URL directly in browser address?
      (e.i.: http://localhost:8080/ScriptsJBoss/myCGI.exe)

      thanks,
      Joni.

        • 1. Re: myCGI.exe in browser address
          Joni Soares Newbie

           

          "JoniJBOSS" wrote:
          Hi,

          I have a myCGI.exe that works fine with IIS(inserting the URL in the browser address), but when I use it in JBOSS and then it tries to download the file(myCGI.exe) the problem happens: the download is the problem, i don't want to download the file, i want to execute the file and it generates my webfiles.

          where can i set (in JBOSS) to execute my cgi file without making the download when inserting the URL directly in browser address?
          (e.i.: http://localhost:8080/ScriptsJBoss/myCGI.exe)

          thanks,
          Joni.


          Hellou,

          ok, BUT, in "jboss-4.0.3SP1.zip" the file servlets-cgi.renametojar don't exists!!!

          Please, where i can find this file ??

          thanks for help!

          Joni.

          -----------------------------------------------------------------------------

          To enable Tomcat?s CGI servlet, you must do the following:

          1. Rename the file servlets-cgi.renametojar (found in CATALINA_HOME/server/lib/) to servlets-cgi.jar, so that the servlet that processes CGI scripts will be on Tom- cat?s CLASSPATH.

          2. In Tomcat?s web.xml file, uncomment the definition of the servlet named cgi (this is around line 235 in the distribution).

          3. Also in Tomcat?s web.xml, uncomment the servlet mapping for the cgi servlet (around line 290 in the distributed file). Remember, this specifies the HTML links to the CGI script.

          4. Either place the CGI scripts under the WEB-INF/cgi directory (remember that WEB-INF is a safe place to hide things that you don?t want the user to be able to view for security reasons), or place them in some other directory within your context and adjust the cgiPathPrefix parameter (see Table 2-10) to identify the directory containing the files. This specifies the actual location of the CGI scripts, which typically will not be the same as the URL in the previous step.

          5. Restart Tomcat, and your CGI processing should now be operational.



          • 2. Re: myCGI.exe in browser address
            Bruce Barkstrom Newbie

            The fix that uses CATALINA_HOME/server/lib/servlets-cgi.renametojar
            doesn't appear to exist in the jboss-4.0.2 download
            for Windows. Using the Windows directory search
            for cgi - either on file contents or on file names does
            not bring up any hits except from the lines in the
            web.xml file that contain "cgi".

            Bruce B

            • 3. Re: myCGI.exe in browser address
              kelly hays Newbie

              The files you are looking for aren't in the jboss download but are in the TomCat server:


              Servlet-cgi:
              Tomcat 5.5\server\lib


              The web.xml:
              \Tomcat 5.5\conf

              But, I still don't know what to do with these in jboss