1 Reply Latest reply on Sep 11, 2004 10:11 PM by Scott Stark

    error of deploy

    Carlos Evangelista Newbie

      It sees the code below:

      <!DOCTYPE ejb-jar PUBLIC "-//Sun Microsystems, Inc.//DTD Enterprise JavaBeans 2.0//EN" "http://java.sun.com/dtd/ejb-jar_2_0.dtd">
      <ejb-jar>
       <description>Sibnc</description>
       <enterprise-beans>
       <session>
       <ejb-name>CustomersBean</ejb-name>
       <home>ejb.CustomersHome</home>
       <remote>ejb.Customers</remote>
       <ejb-class>ejb.CustomersBean</ejb-class>
       <session-type>Stateless</session-type>
       <transaction-type>Container</transaction-type>
       </session>
       </enterprise-beans>
       <assembly-descriptor>
       <security-role>
       <role-name>everyone</role-name>
       </security-role>
       <method-permission>
       <role-name>everyone</role-name>
       <ejb-name>CustomersBean</ejb-name>
       <method-name>*</method-name>
       </method-permission>
       <container-transaction>
       <ejb-name>CustomersBean</ejb-name>
       <method-name>*</method-name>
       <trans-attribute>Required</trans-attribute>
       </container-transaction>
       </assembly-descriptor>
      </ejb-jar>
      
      Why ?
      
      10:47:28,217 ERROR [MainDeployer] could not create deployment: file:/C:/jboss-3.2.3/server/default/deploy/sibnc.ear
      org.jboss.deployment.DeploymentException: Error in ejb-jar.xml, in method-permission: An unchecked element or one or more role-name elements must be specified in method-permission.
      
      Somebody can help.
      
      
      
      


        • 1. Re: error of deploy
          Scott Stark Master

          Because the method-permission element in your doc:

           <method-permission>
           <role-name>everyone</role-name>
           <ejb-name>CustomersBean</ejb-name>
           <method-name>*</method-name>
           </method-permission>
          


          bears no resemblence to the method-permission described in the DOCTYPE you claim to conform to:

          <!ELEMENT method-permission (description?, (role-name+|unchecked), method+)>