1 Reply Latest reply on Feb 7, 2006 8:57 AM by Seth Buntin

    Help with login-config.xml configuration

    Seth Buntin Newbie

      I am trying to set up my Active Directory configuration for this web application and it doesn't seem to be working. Maybe someone can help me...

      Here is where my users are located:

      msunet2k.edu
       Academic
       COE
       User
      


      Here is where my group is that has what users I want to use this app:

      msunet2k.edu
       Academic
       COE
       User
       Web Groups
       COE_GG_WEB_KATE (actual name of group)
      


      Here is what I currently have in my login-config.xml file:

       <application-policy name="kwormSecurity">
       <authentication>
       <login-module code="org.jboss.security.auth.spi.LdapLoginModule" flag="required" >
       <module-option name="java.naming.provider.url">ldap://drawbridge.msunet2k.edu</module-option>
       <module-option name="rolesCtxDN">ou=User,ou=COE,ou=Academic,dc=msunet2k,dc=edu</module-option>
       <module-option name="matchOnUserDN">false</module-option>
       <module-option name="principalDNSuffix">@msunet2k.edu</module-option>
       <module-option name="principalDNPrefix">userPrincipalName</module-option>
       <module-option name="uidAttributeID">userPrincipalName</module-option>
       <module-option name="roleAttributeID">memberOf</module-option>
       <module-option name="roleAttributeIsDN">true</module-option>
       <module-option name="roleNameAttributeID">name</module-option>
       </login-module>
       </authentication>
       </application-policy>
      


      Am I missing something?