0 Replies Latest reply on Mar 21, 2004 1:29 PM by sahumx

    Messages going missing

    sahumx Newbie

      I have que to which I send messages through a session bean:
      Configuration given below:
      <ejb-name>XXXXX</ejb-name>
      <resource-ref>
      <res-ref-name>jms/QueueConnectionFactory
      </res-ref-name>
      <jndi-name>ConnectionFactory</jndi-name>
      </resource-ref>
      <resource-env-ref>
      <resource-env-ref-name>jms/AsyncSenderQueue</resource-env-ref-name>
      <jndi-name>queue/jms/opc/OrderQueue</jndi-name>
      </resource-env-ref>
      The log seem to say that it is getting send to the queue
      Duke Express


      JETBLACK
      JB-2
      JB-2-1
      0
      1
      145.0



      }
      }
      2004-03-21 18:24:21,578 TRACE [org.jboss.mq.SpyXAResourceManager] TXState=org.jboss.mq.SpyXAResourceManager$TXState@10cceb3{ txState=0, sendMessages=[], ackedMessages=[] }
      2004-03-21 18:24:21,578 TRACE [org.jboss.mq.Connection] Closing sessions, ClientID=ID:10
      2004-03-21 18:24:21,578 DEBUG [org.jboss.mq.SpySession] Session closing.
      2004-03-21 18:24:21,578 TRACE [org.jboss.mq.Connection] PING
      2004-03-21 18:24:21,578 TRACE [org.jboss.mq.server.TracingInterceptor] CALLED : ping
      2004-03-21 18:24:21,578 TRACE [org.jboss.mq.server.TracingInterceptor] ARG : 1079893461578
      2004-03-21 18:24:21,578 DEBUG [org.jboss.mq.il.oil.OILClientIL] ConnectionReceiverOILClient is connecting to: 81.101.228.236:1790
      2004-03-21 18:24:21,593 TRACE [org.jboss.mq.SpyXAResourceManager] Ending xid=-9223372036854775808, success=true
      2004-03-21 18:24:21,593 TRACE [org.jboss.mq.SpyXAResourceManager] Rolling back xid=-9223372036854775808
      2004-03-21 18:24:21,593 TRACE [org.jboss.mq.Connection] PONG, serverIL=org.jboss.mq.il.oil.OILServerIL@142d884
      2004-03-21 18:24:21,593 TRACE [org.jboss.mq.server.TracingInterceptor] RETURN : ping
      2004-03-21 18:24:21,593 TRACE [org.jboss.mq.server.TracingInterceptor] CALLED : transact
      2004-03-21 18:24:21,593 TRACE [org.jboss.mq.server.TracingInterceptor] ARG : org.jboss.mq.TransactionRequest@9a4f8e
      2004-03-21 18:24:21,593 TRACE [org.jboss.mq.server.TracingInterceptor] RETURN : transact
      2004-03-21 18:24:21,593 TRACE [org.jboss.mq.SpyXAResourceManager] Starting tx with new xid=-9223372036854775807
      2004-03-21 18:24:21,609 TRACE [org.jboss.mq.SpySession] Current transaction id: -9223372036854775807
      2004-03-21 18:24:21,609 TRACE [org.jboss.mq.Connection] Closed sessions
      2004-03-21 18:24:21,609 DEBUG [org.jboss.mq.Connection] Notifiying the server of close
      2004-03-21 18:24:21,609 TRACE [org.jboss.mq.server.TracingInterceptor] CALLED : connectionClosing
      2004-03-21 18:24:21,609 TRACE [org.jboss.mq.il.oil.OILClientIL] Closing OILClientIL
      2004-03-21 18:24:21,609 TRACE [org.jboss.mq.server.TracingInterceptor] RETURN : connectionClosing
      2004-03-21 18:24:21,609 TRACE [org.jboss.mq.Connection] Stoping the ClientIL service.....

      But Nothing seems to be appearing...
      The MDB does not seem to pickup the message and also I do not see any messages in the queue depth..
      I do not know what is going wrong..
      Please do inform what can be the reason...