1 Reply Latest reply on Oct 6, 2004 3:42 PM by Frank Grimes

    JBoss + AIX + java.lang.NullPointerException at org.mortbay.

    Przemslaw Peret Newbie

      Hi all,

      Deployement environment configuration is:
      - Java version: 1.4.1,IBM Corporation
      - OS-System: AIX 5.2
      - JBoss-3.0.3

      Application was developed and built under:
      - Java version: 1.4.1, Sun Microsystems
      - OS-System: Win XP
      - JBoss-3.0.3

      Deployement proccess of the application looked good. No errors occured. Part of the application worked fine but when I tried to access some other jsps I got HTTP500 error and the following information on JBoss console:

      2004-08-24 14:37:11,939 WARN [org.jboss.jbossweb] WARNING: Exception for /app/com/inet/viewer/ReportViewerBean.class
      java.lang.NullPointerException
      at org.mortbay.http.PathMap.pathMatch(PathMap.java(Compiled Code))
      at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:561)
      at org.mortbay.http.HttpContext.handle(HttpContext.java(Compiled Code))
      at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.java:544)
      at org.mortbay.http.HttpContext.handle(HttpContext.java(Compiled Code))
      at org.mortbay.http.HttpServer.service(HttpServer.java(Compiled Code))
      at org.jboss.jetty.Jetty.service(Jetty.java:541)
      at org.mortbay.http.HttpConnection.service(HttpConnection.java(Inlined Compiled Code))
      at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java(Compiled Code))
      at org.mortbay.http.HttpConnection.handle(HttpConnection.java:802)
      at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:200)
      at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:294)
      at org.mortbay.util.ThreadPool$JobRunner.run(ThreadPool.java(Compiled Code))
      at java.lang.Thread.run(Thread.java:568)

      Whole application works fine under following configuration:
      - Java version: 1.4.1, Sun Microsystems
      - OS-System: Solaris/Win XP
      - JBoss-3.0.3

      Any ideas why the same application works fine with Sun Java and does not work with IBM Java??

      Best regards
      Przemek