0 Replies Latest reply on Nov 3, 2004 3:46 PM by Roger Hand

    JBossMQ Standalone install on 4.0.0 - fix

    Roger Hand Newbie

      I attempted to install JBossMQ standalone by following the instructions at http://www.jboss.org/wiki/Wiki.jsp?page=IsThereAStandaloneDistributionOfJBossMQ, but ended up with the following bottom-line error:

      MBEANS THAT ARE THE ROOT CAUSE OF THE PROBLEM:
      ObjectName: jboss.jca:name=DefaultDS,service=DataSourceBinding
       state: NOTYETINSTALLED
       I Depend On:
       Depends On Me: jboss.mq:service=PersistenceManager


      Examining the build.xml file, I see that it makes reference to the file jboss-jca.sar, which I couldn't find anywhere in JBoss 4.0.0. So perhaps this file was never updated from JBoss 3.x?

      In any case, after a long night of poking around, I got the default hsqldb JBossMQ to work. Here is what was missing from build.xml:
      <fileset>
       <...>
       <!-- missing from original (3.x?) build.xml -->
       <include name="conf/standardjbosscmp-jdbc.xml"/>
       <include name="deploy/jbossjca-service.xml"/>
       <include name="deploy/jboss-jdbc-metadata.sar"/>
       <include name="deploy/jms/hsqldb-jdbc-state-service.xml"/>
       <include name="lib/jboss-jca.jar"/>
      </fileset>


      In addition, here's what I needed to add to the bottom of jboss-service.xml

      <!-- Added by Roger Hand. See http://jboss.com/index.html?module=bb&op=viewtopic&t=54155 -->
       <!-- RMI/JRMP invoker -->
       <mbean code="org.jboss.invocation.jrmp.server.JRMPInvoker"
       name="jboss:service=invoker,type=jrmp">
       <attribute name="RMIObjectPort">4444</attribute>
       <attribute name="ServerAddress">${jboss.bind.address}</attribute>
       <!--
       <attribute name="RMIClientSocketFactory">custom</attribute>
       <attribute name="RMIServerSocketFactory">custom</attribute>
       <attribute name="SecurityDomain">ssl-domain-name</attribute>
       -->
      
       <depends>jboss:service=TransactionManager</depends>
       </mbean>
      </server>


      I altered these two files in docs/examples/jms/standalone, then ran ant and then it ran fine.