10 Replies Latest reply on Aug 18, 2010 2:34 PM by Cesar William

    JBoss 5 JOPR plugin does not work with jopr 2.3.0 b1142

    Zbigniew Łuszpiński Newbie

      Hello,

      I run everything on one machine and use all default values.
      1. I have just installed jopr-server-2.3.0 b1142 and run it
      2. From this jopr server rhq-enterprise-agent-1.3.0.jar was extracted and installed (using jopr server gui).
      3. Then I built from svn repository today jopr-jboss-as-5-plugin-2.3.0-SNAPSHOT.jar and deployed it on jopr server.
      4. I installed and run jboss 5.0.0.GA 5.0.1GA 5.1.0.GA
      5. Now I run jopr-agent. Agent executed successfuly, autodownloaded all plugins from jopr server and detected correctly everything except JBoss5. None of JBoss5 appeared on jopr server dashboard. I only see in dashboard JBoss 4.2.3 which is used by server, agent and everything except JBoss5. None of JBoss 5.0.0/5.0.1/5.1.0 was detected.

      The JBoss5 plugin is not rejected, is visible on jopr-server list of plugins:

      JBoss Application Server 5.x Supports management and monitoring of JBoss AS from version EAP 5 9/11/09, 4:28:30 PM, CEST true

      I have just run jopr-agent console and discovery command return this:
      JBossAS5.JBossAS Server: Starting discovery...
      JBossAS5.JBossAS Server: Process scan detected a server - scan=[ProcessScan: query=[process|basename|match=^java.*,arg|org.jboss.Main|match=.*], name=[jbossas]], process=[process: pid=[11266], name=[/usr/java/jdk1.6.0_16/bin/java], ppid=[11244]]
      JBossAS5.JBossAS Server: Process scan detected a server - scan=[ProcessScan: query=[process|basename|match=^java.*,arg|org.jboss.Main|match=.*], name=[jbossas]], process=[process: pid=[10859], name=[/usr/java/jdk1.6.0_16/bin/java], ppid=[10849]]
      JBossAS5.JBossAS Server: Done.
      

      So on agent side plugin also works and detects JBoss5.
      But this detected JBoss5 is not visible on dashboard and not autodetected by jopr server.

        • 1. Re: JBoss 5 JOPR plugin does not work with jopr 2.3.0 b1142
          Ian Springer Master

          The Agent is actually not discovering the AS5 servers you see in the output of the discovery Agent prompt command. The output of the discovery command is a bit misleading. A line such as:

          JBossAS5.JBossAS Server: Process scan detected a server - scan=[ProcessScan: query=[process|basename
          |match=^java.*,arg|org.jboss.Main|match=.*], name=[jbossas]], process=[process: pid=[11266], name=[/
          usr/java/jdk1.6.0_16/bin/java], ppid=[11244]]


          only indicates that the RHQ plugin container found a process that matches the process query described by the plugin. The AS5 plugin then does further filtering of the list of AS processes and discovers Resources only for those that are versions supported by the plugin. The plugin only support EAP 5.0 and later. That is, it does not support AS 5.0.x or 5.1.x. It should support AS 5.2 when it's released.

          When a AS5 server is actually discovered, the discovery command will print a line such as:

          JBossAS5.JBossAS Server: key=[C:\opt\jboss-eap-5.0.0-SNAPSHOT\server\default], name=[MAINFRAME JBoss EAP 5.0.3.Branch default (127.0.0.50:1099)], version=[5.0.3
          .Branch], description=[JBoss Enterprise Application Platform]
          


          This means it was a version of AS or EAP that the plugin supports.


          • 2. Re: JBoss 5 JOPR plugin does not work with jopr 2.3.0 b1142
            August Simonelli Newbie

            Thanks ips for this - it was quite useful for me as i was having the same issue. Got all excited about jopr2.3 jbossworld tweet cause i thought it could finally see my AS5.1 instances. Depressed to find out i was wrong - but at least i know i'm not crazy! :-)

            strange that the community edition supports ONLY enterprise stuff at first. i sort of thought:

            jopr and community jboss (AS) we together

            and

            jon and EAP (red hat) were together.

            but i guess as 5.2 will correct that ...

            august

            • 3. Re: JBoss 5 JOPR plugin does not work with jopr 2.3.0 b1142
              Ian Springer Master

              Hi August,

              The reason is that we didn't start working on the AS5 plugin, outside of an EmbJopr (i.e. Admin Console) context, until after AS 5.1 had already been released. While working on the code to connect remotely to the Profile Service (i.e. from the AS5 plugin running inside the Jopr Agent), we discovered some bugs in the remote interface to the PS. These were all fixed in the EAP 5.0 branch, the AS 5.2 branch, and trunk, but since they remain in AS 5.1, it isn't supported by Jopr.

              -Ian

              • 4. Re: JBoss 5 JOPR plugin does not work with jopr 2.3.0 b1142
                August Simonelli Newbie

                Ian,

                Thanks for the response! I forgot about the speedy release cycles of community projects - which is what makes them so good.

                It's also an interesting point for me to make to my management around the value of the EAP stuff. This is a perfect illustration of how the community development works so darn well to support the enterprise products; which means buying those products is GOLD and brings a lot of added value!

                Ok, off to work with more jopr stuff ... already got another post on another topic about mysql to make :-)

                Thanks again!

                August

                • 5. Re: JBoss 5 JOPR plugin does not work with jopr 2.3.0 b1142
                  Zbigniew Łuszpiński Newbie

                  I still have problems :(
                  1. I removed jopr agent and server.
                  2. Installed fresh jopr-server and agent 2.3.1 b1212
                  3. Build Jboss5 plugin today from svn: r1224
                  4. deployed it on server and agent
                  5. Executed JBoss 5.0.0.BETA EAP (30-day trial)
                  I see it autodetected but it ends up in dashboard with red exclamation mark in availability and monitoring it is not possible.

                  Using agents's discovery from commandline finds JBoss correctly:

                  JBossAS5.JBossAS Server: Starting discovery...
                  JBossAS5.JBossAS Server: Process scan detected a server - scan=[ProcessScan: query=[process|basename|match=^java.*,arg|org.jboss.Main|match=.*], name=[jbossas]], process=[process: pid=[15589], name=[/usr/java/jdk1.6.0_16/bin/java], ppid=[15579]]
                  JBossAS5.JBossAS Server: Process scan detected a server - scan=[ProcessScan: query=[process|basename|match=^java.*,arg|org.jboss.Main|match=.*], name=[jbossas]], process=[process: pid=[17119], name=[/usr/java/jdk1.6.0_16/bin/java], ppid=[17085]]
                  JBossAS5.JBossAS Server: key=[/opt/jboss-eap-5.0/jboss-as/server/default], name=[jboss-2.altkom.local JBoss EAP 5.0.0.BETA default (0.0.0.0:1099)], version=[5.0.0.BETA], description=[JBoss Enterprise Application Platform]
                  JBossAS5.JBossAS Server: Done.
                  


                  • 6. Re: JBoss 5 JOPR plugin does not work with jopr 2.3.0 b1142
                    Lukas Krejci Apprentice

                    This might not be a problem, but rather a feature.. :)

                    I believe that EAP installation is secured for remote access by default and further the remote JNP and JMX access is disabled altogether.

                    You check that by trying to access /jmx-console web app. If it asks for user/pass, you've got your instance secured.

                    In order to enable remote logins, you have to modify $SERVER_HOME/conf/props/jmx-console-user.properties and uncomment the default user.

                    After doing this (no restart needed) you should be able to login into /jmx-console using those credentials.

                    For Jopr to be able to connect to the EAP instance, you have to provide these credentials to it. You do that in the Inventory/Connection subtab...

                    • 7. Re: JBoss 5 JOPR plugin does not work with jopr 2.3.0 b1142
                      Zbigniew Łuszpiński Newbie

                      Thanks for reply. Indeed admin/admin login and password were commented out. Now I can login to /jmx-console but in dashboard there is still red exclamation mark :(
                      I have done availability rescan and agent restart. Nothing helps.
                      The PrincipalCredentials are greyed out/inactive in Inventory/Connection subtab of JBoss EAP 5.0.0. I can not type in anything.

                      • 8. Re: JBoss 5 JOPR plugin does not work with jopr 2.3.0 b1142
                        mazz Master

                        Sorry for the stupid question but.... did you hit the "Edit" button in the Inventory>Connection page? :)

                        When you initially go to that page, you get a non-editable view of the connection properties - you edit the values by clicking the "edit" button, changing the values, then hitting the "OK" button.

                        The edit button is, annoyingly, only at the very bottom of the page. You have to scroll all the way down to do it. We really should put an edit button at the top, too.

                        • 9. Re: JBoss 5 JOPR plugin does not work with jopr 2.3.0 b1142
                          Zbigniew Łuszpiński Newbie

                           

                          "mazz" wrote:
                          Sorry for the stupid question but.... did you hit the "Edit" button in the Inventory>Connection page? :)


                          Do not feel sorry. This is it. :D

                          "mazz" wrote:

                          The edit button is, annoyingly, only at the very bottom of the page. You have to scroll all the way down to do it. We really should put an edit button at the top, too.


                          Good idea.

                          Thanks all for help. Now I have everything working.