3 Replies Latest reply on Apr 24, 2007 12:08 PM by Sergey Smirnov

    datascroller stoped working

    Tiago Alves Newbie

      Hello

      i was using datascroller a few days ago and it was working properly. But it had a problem. The renderedIfSinglePage="false" wasn´t working.

      After i changed to richfaces-3.0.1-20070419.001036-23.jar the problem with renderdIfSinglePage="false" worked fine... But the dataScroller stoped working. When clicking in the page numbers, nothing changes in the datatable..

      The a4j:log shows this after sending the querystring (warn message in 5th line):

      debug[16:52:54,057]: Header Ajax-Update-Ids not found, search in <meta>
      debug[16:52:54,057]: search for elements by name 'meta' in element #document
      debug[16:52:54,089]: selectNodes found 2
      debug[16:52:54,104]: Find <meta name='Ajax-Update-Ids' content=''>
      warn[16:52:54,104]: No information in response about elements to replace
      debug[16:52:54,120]: call selectSingleNode for id= ajax-update-ids
      debug[16:52:54,136]: Hidden JSF state fields:
      debug[16:52:54,136]: search for elements by name 'input' in element span
      debug[16:52:54,151]: selectNodes found 3
      debug[16:52:54,167]: Replace value for inputs: 39 by new values: 3
      debug[16:52:54,167]: Input in response: jsf_tree_64
      debug[16:52:54,182]: Found same input on page with type: hidden
      debug[16:52:54,198]: Found same input on page with type: hidden
      debug[16:52:54,198]: Found same input on page with type: hidden
      debug[16:52:54,214]: Input in response: jsf_state_64
      debug[16:52:54,229]: Found same input on page with type: hidden
      debug[16:52:54,245]: Found same input on page with type: hidden
      debug[16:52:54,261]: Found same input on page with type: hidden
      debug[16:52:54,276]: Input in response: jsf_viewid
      debug[16:52:54,276]: Found same input on page with type: hidden
      debug[16:52:54,292]: Found same input on page with type: hidden
      debug[16:52:54,307]: Found same input on page with type: hidden
      debug[16:52:54,307]: search for elements by name 'INPUT' in element span
      debug[16:52:54,323]: selectNodes found 0
      debug[16:52:54,323]: Replace value for inputs: 39 by new values: 0
      debug[16:52:54,339]: call selectSingleNode for id= _A4J.AJAX.focus


      What can i do ?? i tried using the richface´s and ajax4jsf´s today´s snapshot but still doesn´t work...