13 Replies Latest reply on May 2, 2002 11:02 AM by Adrian Brock

    JBoss-3.0.0RC1 does not redeploy MBean

    Qingxian Wang Newbie

      I am using JBoss-3.0.0RC1 on Windows2000. When I redeploy, using hot-deploy, a SAR file for a MBean, the existing MBean is not undeployed and the existing SAR file is not replaced. There is no any message come to the app server's console.

      Any idea how to make the hot redeploy work?

      Regards,

      qwang

        • 1. Re: JBoss-3.0.0RC1 does not redeploy MBean
          Adrian Brock Master

          More info please.

          You asked this before in another post, but all you posted
          was that the manifests could not be found and that it
          didn't work.

          Can you explain the packaging.
          Does it deploy and run correctly the first time?
          Have you tried with latest CVS, RC2 should be out soon?

          The most common reason for deployment stopping is because
          a deployment hangs. e.g. a database url is misspelt
          and the connection hangs forever. Maybe you have the
          same problem?

          Can you hot deploy other things besides your SAR.
          Try touching jetty-plugin.sar or tomcat4-service.xml
          to see whether they redeploy.

          Regards,
          Adrian

          • 2. Re: JBoss-3.0.0RC1 does not redeploy MBean
            Qingxian Wang Newbie

            Hi Adrian,

            In hot deployment, the MBean always get deployed first time although there appear those error or warning messages, and its operations can be invoked without problem. But subsequent redeployment has no response from the server. EAR files can be redeployed many times.

            In static deployment (i.e. copy SAR to deploy directory and then start the server), there is no exception message saying "Class not found ..." but only warning messages saying like:

            "11:38:22,203 WARN [MainDeployer] The manifest entry in file:/H:/evodev/jboss-3.
            0.0RC1_tomcat-4.0.3/server/default/deploy/framework-deployment.sar references UR
            L file:/H:/evodev/jboss-3.0.0RC1_tomcat-4.0.3/server/default/deploy/library/fram
            ework-repository.jar which could not be opened, entry ignored"

            But the MBean is still deployed and its operations can be invoked without problem.

            I am going to try to use the latest code of RC2 from CVS.

            Thank you.

            qwang

            • 3. Re: JBoss-3.0.0RC1 does not redeploy MBean
              Qingxian Wang Newbie

              Hi Adrian,

              The packaging of my SAR file:

              class files of the MBean and help classes
              xxxxxxxMBean.class
              ...................
              ...................
              library\libjar1.jar
              library\libjar2.jar
              ...................
              META-INF\jboss-service.xml
              META-INF\MANIFEST.MF

              Here are the contents of MANIFEST.MF:

              Manifest-Version: 1.0
              Created-By: Ant 1.4.1
              Class-Path: library/log4j.jar
              library/jdom.jar
              library/xerces.jar
              library/castor-0.9.3.9+-xml.jar
              library/framework-errors.jar
              library/framework-errors-resources.jar
              library/framework-util.jar
              library/framework-util-resources.jar
              library/framework-repository.jar
              library/framework-repository-resources.jar

              Thank you for help.

              qwang

              • 4. Re: JBoss-3.0.0RC1 does not redeploy MBean
                Adrian Brock Master

                I'm still not sure about your problem.

                You start the server and

                framework-deployment.sar is deployed with warnings and
                another.ear is deployed

                You can then redeploy
                another.ear as many times as you like

                If you redeploy framework-deployment.sar you get
                no output from the server but
                when you try to use it you get a ClassNotFoundException?

                Can you check log/server.log, to see whether there
                are debug messages in there?

                Regards,
                Adrian

                • 5. Re: JBoss-3.0.0RC1 does not redeploy MBean
                  Qingxian Wang Newbie

                  Hi Adrian,

                  Sorry for not being able to make the problem clear. Now I don't get the ClassNotFoundException any more.

                  The following is the sequence of my deployment operations:

                  1. Start JBoss server.

                  2. After started JBoss server, start to build and to hot-deploy my MBean, ComponentDeployer, with build.xml.

                  3. The server output the following messages:

                  Starting deployment of package: file:/H:/evodev/Evolution/framework/services/deployment/build/lib/framework-deployment.sar
                  Starting deployment (init step) of package at: file:/H:/evodev/Evolution/framework/services/deployment/build/lib/framework-deployment.sar
                  using deployer org.jboss.deployment.SARDeployer@6fe0f4
                  about to copy 0 local directories
                  resolveLibraries: library/log4j.jar library/jdom.jar library/xerces.jar library/castor-0.9.3.9+-xml.jar library/framework-errors.jar library/framework-errors-resources.jar library/framework-util.jar library/framework-util-resources.jar library/framework-repository.jar library/framework-repository-resources.jar library/framework-persistence.jar library/framework-persistence-resources.jar library/framework-verification.jar library/framework-verification-resources.jar
                  new manifest entry for sdi at framework-deployment.sar entry is library/log4j.jar
                  The manifest entry in file:/H:/evodev/Evolution/framework/services/deployment/build/lib/framework-deployment.sar references URL file:/H:/evodev/Evolution/framework/services/deployment/build/lib/library/log4j.jar which could not be opened, entry ignored
                  new manifest entry for sdi at framework-deployment.sar entry is library/jdom.jar
                  The manifest entry in file:/H:/evodev/Evolution/framework/services/deployment/build/lib/framework-deployment.sar references URL file:/H:/evodev/Evolution/framework/services/deployment/build/lib/library/jdom.jar which could not be opened, entry ignored
                  .................................. (omitted other lines)
                  found 15 subpackages of file:/H:/evodev/Evolution/framework/services/deployment/build/lib/framework-deployment.sar
                  Starting deployment (init step) of package at: njar:file:/H:/evodev/jboss-3.0.0RC1_tomcat-4.0.3/server/default/tmp/deploy/H/evodev/Evolution/framework/services/deployment/build/lib/framework-deployment.sar/95.framework-deployment.sar^/library/log4j.jar
                  no xmls found
                  using deployer org.jboss.deployment.JARDeployer@148bd3
                  found 0 subpackages of njar:file:/H:/evodev/jboss-3.0.0RC1_tomcat-4.0.3/server/default/tmp/deploy/H/evodev/Evolution/framework/services/deployment/build/lib/framework-deployment.sar/95.framework-deployment.sar^/library/log4j.jar
                  Starting deployment (init step) of package at: njar:file:/H:/evodev/jboss-3.0.0RC1_tomcat-4.0.3/server/default/tmp/deploy/H/evodev/Evolution/framework/services/deployment/build/lib/framework-deployment.sar/95.framework-deployment.sar^/library/xerces.jar
                  no xmls found
                  .................................. (omitted other lines)
                  Watching new file: file:/H:/evodev/Evolution/framework/services/deployment/build/lib/framework-deployment.sar
                  create step for deployment file:/H:/evodev/Evolution/framework/services/deployment/build/lib/framework-deployment.sar
                  create step for deployment njar:file:/H:/evodev/jboss-3.0.0RC1_tomcat-4.0.3/server/default/tmp/deploy/H/evodev/Evolution/framework/services/deployment/build/lib/framework-deployment.sar/95.framework-deployment.sar^/library/log4j.jar
                  Done with create step of deploying log4j.jar
                  create step for deployment njar:file:/H:/evodev/jboss-3.0.0RC1_tomcat-4.0.3/server/default/tmp/deploy/H/evodev/Evolution/framework/services/deployment/build/lib/framework-deployment.sar/95.framework-deployment.sar^/library/xerces.jar
                  Done with create step of deploying xerces.jar
                  .................................. (omitted other lines)
                  Deploying SAR, create step: url file:/H:/evodev/Evolution/framework/services/deployment/build/lib/framework-deployment.sar
                  About to create bean: SystemsUnion:service=ComponentDeployer
                  ....................... (omitted other lines)
                  Final (start) deployment step successfully completed on package: log4j.jar
                  start step for deployment njar:file:/H:/evodev/jboss-3.0.0RC1_tomcat-4.0.3/server/default/tmp/deploy/H/evodev/Evolution/framework/services/deployment/build/lib/framework-deployment.sar/95.framework-deployment.sar^/library/xerces.jar
                  Final (start) deployment step successfully completed on package: xerces.jar
                  .................................. (omitted other lines)
                  Deploying SAR, start step: url file:/H:/evodev/Evolution/framework/services/deployment/build/lib/framework-deployment.sar
                  start(): Started EvoDeployer MBean
                  Final (start) deployment step successfully completed on package: framework-deployment.sar
                  Successfully completed deployment of package: file:/H:/evodev/Evolution/framework/services/deployment/build/lib/framework-deployment.sar


                  4. Successfully eploy and undeploy a EJB EAR file, test.ear, many times by invoking the methods of the MBean, ComponentDeployer.

                  5. Repeat step2 to redo the hot deployment of the MBean, no output from the server at all to either console or server.log.

                  6. Repeat step 4 successfully.


                  The problem is that the server never output any message to for undeoly and redeploy the MBean.


                  This message might be clearer.

                  Regards

                  qwang

                  • 6. Re: JBoss-3.0.0RC1 does not redeploy MBean
                    Adrian Brock Master

                    Got it, I think.

                    You say you are hot-deploying the sar.
                    The directory mentioned above isn't the normal
                    hot-deploy location
                    i.e. server/default/deploy

                    Have you added your sar's location or its directory to
                    the URL scanner in jboss-service.xml?

                    Hot deploy only works for urls known to the URL scanner.

                    Regards,
                    Adrian

                    • 7. Re: JBoss-3.0.0RC1 does not redeploy MBean
                      Qingxian Wang Newbie

                      Hi Adrian,

                      JBoss-3.0.0RC1 server redo the hot-deploy of the MBean after I added the path of directory of the MBeans SAR file to the URL Scanner. It is a big progress for me. However, the server tries to deploy the same MBean twice each time when the MBean is deployed and the server then throw an exception with error message saying "xxxxxx already registered ....". Although it does not affect the use of the MBean, it puts alot of exception messages on the screen each time the MBean is redeployed.

                      Any further suggestions?

                      Thank you.

                      qwang

                      • 8. Re: JBoss-3.0.0RC1 does not redeploy MBean
                        Adrian Brock Master

                        When YOU redo the hot-deploy?

                        The hot-deploy should be automatic when you change
                        to sar.

                        Regards,
                        Adrian

                        • 9. Re: JBoss-3.0.0RC1 does not redeploy MBean
                          Qingxian Wang Newbie

                          Adrian,

                          I have got it work now. But, I still have a question. Copy SAR file to ./deploy or any URL registered to URLDeploymentScanner set-up is not really what I mean by "hot deploy". By "hot deploy", I mean to deploy a SAR file from a directory that is not registered for deployment scanning, e.g. the one I used before, after the file is built and by calling org.jboss.jmx.client.Deployer in build.xml file.

                          It seems JBoss hasn't got this work for redeploy SAR. First time deploying SAR file works, but not the subsequent deployment.

                          Hope I have made my problem clear.

                          Thanks.

                          qwang

                          • 10. Re: JBoss-3.0.0RC1 does not redeploy MBean
                            Adrian Brock Master

                            Ok,

                            No wonder I couldn't understand your problem :-)

                            You are correct deploy on something that is already
                            deployed does nothing.
                            You have to "-undeploy" it first.

                            Regards,
                            Adrian

                            • 11. Re: JBoss-3.0.0RC1 does not redeploy MBean
                              Qingxian Wang Newbie

                              JBoss-3.0.0RC2 has sorted the problem out. It now can redo the "hot deploy" as I meant. :-)

                              Regards

                              qwang

                              • 12. Re: JBoss-3.0.0RC1 does not redeploy MBean
                                Qingxian Wang Newbie

                                But the RC2 build from the code checked out from CVS hangs at IIOP starting up. :-(

                                qwang

                                • 13. Re: JBoss-3.0.0RC1 does not redeploy MBean
                                  Adrian Brock Master

                                  Is it the address problem?

                                  Do "netstat -a" and check the port is not being used
                                  already. You can change the port in iiop config file
                                  in deploy.

                                  Regards,
                                  Adrian