2 Replies Latest reply on Jun 9, 2004 7:00 PM by townej2

    SingleScheduleProvider and DefaultPartition

    nusa Novice

      Hi all,

      I'm using JBOSS3.2.4RC2.
      I took out the comment in /default/deploy/schedule-manager-service.xml,
      so it looks like this :

      ...
       <!--
       | This MBean is an example of a Schedule Target
       -->
       <mbean code="org.jboss.varia.scheduler.example.SchedulableMBeanExample"
       name="jboss:service=SchedulableMBeanExample">
       </mbean>
       <!-- -->
      
       <!--
       | The Schedule Manager has to be started whenever
       | schedules are needed
       -->
       <mbean code="org.jboss.varia.scheduler.ScheduleManager"
       name="jboss:service=ScheduleManager">
       <attribute name="StartAtStartup">true</attribute>
       </mbean>
       <!-- -->
      
       <!--
       | This is a single schedule Provider which works like the
       | old Scheduler (when a MBean target is used)
       -->
       <mbean code="org.jboss.varia.scheduler.SingleScheduleProvider"
       name="jboss:service=SingleScheduleProvider">
       <depends>jboss:service=ScheduleManager</depends>
       <depends>jboss:service=SchedulableMBeanExample</depends>
       <attribute name="ScheduleManagerName">jboss:service=ScheduleManager</attribute>
       <attribute name="TargetName">jboss:service=SchedulableMBeanExample</attribute>
       <attribute name="TargetMethod">hit( NOTIFICATION, DATE, REPETITIONS, SCHEDULER_NAME, java.lang.String )</attribute>
       <attribute name="DateFormat"></attribute>
       <attribute name="StartDate">NOW</attribute>
       <attribute name="Period">10000</attribute>
       <attribute name="Repetitions">10</attribute>
       </mbean>
       <!-- -->
      ...
      


      If I run JBoss in default mode, I got the following error :

      ...
      16:01:21,049 DEBUG [org.jboss.system.ServiceController] starting service jboss:service=SingleScheduleProvider

      16:01:21,049 DEBUG [org.jboss.varia.scheduler.SingleScheduleProvider] Starting jboss:service=SingleScheduleProvider

      16:01:21,049 DEBUG [org.jboss.varia.scheduler.SingleScheduleProvider] start HASingletonController

      16:01:21,049 DEBUG [org.jboss.varia.scheduler.SingleScheduleProvider] findHAPartitionWithName, name=DefaultPartition

      16:01:21,210 ERROR [org.jboss.varia.scheduler.SingleScheduleProvider] Starting failed jboss:service=SingleScheduleProvider

      javax.management.InstanceNotFoundException: Failed to find HAPartition with PartitionName=DefaultPartition

      at org.jboss.ha.jmx.HAServiceMBeanSupport.findHAPartitionWithName(HAServiceMBeanSupport.java:370)

      at org.jboss.ha.jmx.HAServiceMBeanSupport.setupPartition(HAServiceMBeanSupport.java:168)

      at org.jboss.ha.jmx.HAServiceMBeanSupport.startService(HAServiceMBeanSupport.java:140)

      at org.jboss.varia.scheduler.AbstractScheduleProvider.startService(AbstractScheduleProvider.java:236)

      ...

      Why this HA get involve in default mode ? If I run in mode 'all'( run.bat -c all ), I think I did not get the error.
      Where is it defined DefaultPartition service when you run jboss in default mode ?

      Thanks for any help.