1 Reply Latest reply on Jan 12, 2005 11:56 AM by Andrew Tillman

    Big Problem with Schedulable

    Andrew Tillman Newbie

      I have several Schedulable items that are designed to run at ~5min intervals. There is a ServletContextListener that starts up the items when our application deploys. These schedulable items worked fine for months but now they are giving us problems. When our application starts up the Schedulable items are run once, but are never run again. Even if I go the the jmx-console and tell it to restartSchedule() I see in the logs the the item's constructor is called, but the perform(Date, long) method is never called.

      Any help with this problem would be appreciated as this is affecting a production server.

      Here is the mbeam XML configuration

      <mbean code="org.jboss.varia.scheduler.Scheduler"
       name="backstop:service=ContactSyncTaskService-Owner-108">
       <attribute name="StartAtStartup">false</attribute>
       <attribute name="SchedulableClass">com.backstopsolutions.fundbutter.crm.collaboration.timer.ContactSyncTask</attribute>
       <attribute name="SchedulableArguments">108,10</attribute>
       <attribute name="SchedulableArgumentTypes">java.lang.Integer,int</attribute>
       <attribute name="InitialStartDate">NOW</attribute>
       <attribute name="SchedulePeriod">300000</attribute>
       <attribute name="InitialRepetitions">-1</attribute>
       </mbean>


        • 1. Re: Big Problem with Schedulable
          Andrew Tillman Newbie

          I've looked into this bug more. It seems that one of the Schedulable items is hanging, it makes a network connection and does some work. This seems to stop all other Scheduled items. I was under the impression that this was a threaded operation. In fact, our production server under 3.2.6 didn't have this problem. Is the Scheduled timer threaded?

          "atillman" wrote:
          I have several Schedulable items that are designed to run at ~5min intervals. There is a ServletContextListener that starts up the items when our application deploys. These schedulable items worked fine for months but now they are giving us problems. When our application starts up the Schedulable items are run once, but are never run again. Even if I go the the jmx-console and tell it to restartSchedule() I see in the logs the the item's constructor is called, but the perform(Date, long) method is never called.

          Any help with this problem would be appreciated as this is affecting a production server.

          Here is the mbeam XML configuration
          <mbean code="org.jboss.varia.scheduler.Scheduler"
           name="backstop:service=ContactSyncTaskService-Owner-108">
           <attribute name="StartAtStartup">false</attribute>
           <attribute name="SchedulableClass">com.backstopsolutions.fundbutter.crm.collaboration.timer.ContactSyncTask</attribute>
           <attribute name="SchedulableArguments">108,10</attribute>
           <attribute name="SchedulableArgumentTypes">java.lang.Integer,int</attribute>
           <attribute name="InitialStartDate">NOW</attribute>
           <attribute name="SchedulePeriod">300000</attribute>
           <attribute name="InitialRepetitions">-1</attribute>
           </mbean>