0 Replies Latest reply on Sep 29, 2006 5:58 AM by Maxim Gordienko

    failed to start web module

    Maxim Gordienko Newbie

      I have web module dependant on MBean (plain mbean, not JBoss Service)
      with jboss-web.xml like

      <jboss-web>
       <class-loading>
       <loader-repository>dot.com:loader=MyLoader</loader-repository>
       </class-loading>
      
       <depends>my.service.dot.com:service=MyService</depends>
      </jboss-web>
      

      upon redeployment of referenced MBean a got
      java.lang.NullPointerException
       at org.jboss.web.WebModule.startModule(WebModule.java:82)
       at org.jboss.web.WebModule.startService(WebModule.java:61)
       at org.jboss.system.ServiceMBeanSupport.jbossInternalStart(ServiceMBeanSupport.java:289)
       at org.jboss.system.ServiceMBeanSupport.jbossInternalLifecycle(ServiceMBeanSupport.java:245)
       at sun.reflect.GeneratedMethodAccessor106.invoke(Unknown Source)
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
       at java.lang.reflect.Method.invoke(Method.java:585)
       at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatcher.java:155)
       at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
       at org.jboss.mx.server.Invocation.invoke(Invocation.java:86)
       at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:264)
       at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
       at org.jboss.system.ServiceController$ServiceProxy.invoke(ServiceController.java:978)
      ......
      


      If web module undeployed, and then deployed again everything works fine.
      How can i fix this?

      JBoss is 4.0.4.GA
      Sar dependant on this mbean works just fine

      Thank you.