10 Replies Latest reply on Nov 13, 2009 3:24 AM by Tom Jenkinson

    fooapp example failed

    Chuanbin Xu Newbie

      Hi,

      1, I finished the steps specified by the infomation of the link (http://www.jboss.org/community/wiki/DeployingBlacktie).

      (1)no complains in "ant jts", changed the word CONFIGURATION_FILE to

      "NAME_SERVICE".

      (2) copied the files of <BLACKTIE_BIN_DIR> into the <JBOSS_HOME>

      (3)no complains of the compiles

      2, %JBOSS_HOME%/bin/run.bat -c all

      server -c win32 -i 1

      An application error errored:

      "The application failed to initialize properly(0xc0150002). Click OK to terminate the application".

      3, with http://localhost:8080/admin-console/

      I found "Blactkie Domains" --> "fooapp" --> "Servers"

      "default" (red cross)
      "foo" (red cross)

      How can I solve the problem?


      Thanks a lot for any help!

      Best regards,

      Sunny

      [/img]

        • 1. Re: fooapp example failed
          Amos Feng Apprentice

          Hi Sunny,

          Thanks for your interest in BlackTie !
          I appreciate if you can paste up blacktie.log in <BLACKTIE_BIN_DIR>/examples/xatmi/fooapp/

          We could get more details about what happened in your machine.

          Amos

          • 2. Re: fooapp example failed
            Chuanbin Xu Newbie

            Hi Amos,

            I couldn't find the blacktie.log in <BLACKTIE_BIN_DIR>/examples/xatmi/fooapp/.

            my cmd line is: server -c win32 -i 1

            -------------------

            default's error in admin-console

            ----------

            java.lang.Exception: call default_ADMIN_1 command advertise,BAR, failed with org.jboss.blacktie.jatmibroker.xatmi.ConnectionException: Could not create a service sender: default_ADMIN_1 not bound: -1
            at org.rhq.core.pc.operation.OperationInvocation.run(OperationInvocation.java:278)
            at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
            at java.lang.Thread.run(Thread.java:619)
            foo's error in admin-console
            ----------
            java.lang.Exception: call foo_ADMIN_1 command advertise,BAR, failed with org.jboss.blacktie.jatmibroker.xatmi.ConnectionException: Could not create a service sender: foo_ADMIN_1 not bound: -1
            at org.rhq.core.pc.operation.OperationInvocation.run(OperationInvocation.java:278)
            at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
            at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
            at java.lang.Thread.run(Thread.java:619)

            -------------------
            jboss' server.log:

            2009-11-09 11:59:47,437 WARN [org.rhq.core.system.SystemInfoFactory] (http-127.0.0.1-8080-1) System info API not accessible on this platform (native shared library not found in java.library.path).

            2009-11-09 12:00:15,296 WARN [org.jboss.managed.plugins.factory.AbstractManagedObjectPopulator] (ResourceDiscoveryComponent.invoker.daemon-1) Cannot create String name from non-Simple property: ManagedProperty{JNDIName,JNDIName,metaType=SimpleMetaType:java.lang.String}, value=null

            2009-11-09 12:00:19,375 INFO [com.arjuna.ats.txoj.logging.txojLoggerI18N] (Thread-23) [com.arjuna.ats.internal.txoj.recovery.TORecoveryModule_3] - TORecoveryModule - first pass

            2009-11-09 12:00:29,375 INFO [com.arjuna.ats.txoj.logging.txojLoggerI18N] (Thread-23) [com.arjuna.ats.internal.txoj.recovery.TORecoveryModule_6] - TORecoveryModule - second pass
            -------------

            jboss's boot log:

            11:56:38,765 DEBUG [ProfileServiceBootstrap] Failed to build ManagedDeployment for: AbstractKernelDeployment@16acad2{name=file:/K:/blacktie/blacktie_util/jboss-5.1.0.GA/server/all/conf/bootstrap/logging.xml installed=true beanFactories=[AbstractBeanMetaData@29b849{name=LogBridgeHandler bean=org.jboss.logbridge.LogBridgeHandler properties= constructor=null autowireCandidate=true}]}
            org.jboss.deployers.spi.DeploymentException: Error deploying: file:/K:/blacktie/blacktie_util/jboss-5.1.0.GA/server/all/conf/bootstrap/logging.xml
            at org.jboss.deployers.spi.DeploymentException.rethrowAsDeploymentException(DeploymentException.java:49)
            at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.deploy(BeanMetaDataFactoryVisitor.java:136)
            at org.jboss.system.server.profileservice.ProfileServiceBootstrap.initBootstrapMDs(ProfileServiceBootstrap.java:433)
            at org.jboss.system.server.profileservice.ProfileServiceBootstrap.start(ProfileServiceBootstrap.java:250)
            at org.jboss.bootstrap.AbstractServerImpl.start(AbstractServerImpl.java:461)
            at org.jboss.Main.boot(Main.java:221)
            at org.jboss.Main$1.run(Main.java:556)
            at java.lang.Thread.run(Thread.java:619)
            Caused by: java.lang.IllegalStateException: ClassLoader has not been set
            at org.jboss.deployers.structure.spi.helpers.AbstractDeploymentUnit.getClassLoader(AbstractDeploymentUnit.java:154)
            at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.addBeanComponent(BeanMetaDataFactoryVisitor.java:60)
            at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.deploy(BeanMetaDataFactoryVisitor.java:126)
            ... 6 more
            11:56:38,765 DEBUG [AbstractDeploymentContext] Added component VFSCache$realCache#1 to file:/K:/blacktie/blacktie_util/jboss-5.1.0.GA/server/all/conf/bootstrap/vfs.xml
            11:56:38,765 DEBUG [ProfileServiceBootstrap] Failed to build ManagedDeployment for: AbstractKernelDeployment@14c02d4{name=file:/K:/blacktie/blacktie_util/jboss-5.1.0.GA/server/all/conf/bootstrap/vfs.xml installed=true beanFactories=[AbstractBeanMetaData@14db52b{name=VFSCache bean=null properties=[realCache, permanentRoots] constructor=AbstractConstructorMetaData@3468f4{parameters=[null] factoryClass=org.jboss.virtual.spi.cache.VFSCacheFactory factoryMethod=getInstance} autowireCandidate=true start=AbstractLifecycleMetaData@d67067{ whenRequired=ControllerState@b124fa{Start} parameters= }}, AbstractBeanMetaData@1f2a9da{name=VfsNamesExceptionHandler bean=org.jboss.virtual.plugins.context.helpers.NamesExceptionHandler properties= constructor=AbstractConstructorMetaData@6d4f30{parameters=[java.lang.String]} autowireCandidate=true}]}
            org.jboss.deployers.spi.DeploymentException: Error deploying: file:/K:/blacktie/blacktie_util/jboss-5.1.0.GA/server/all/conf/bootstrap/vfs.xml
            at org.jboss.deployers.spi.DeploymentException.rethrowAsDeploymentException(DeploymentException.java:49)
            at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.deploy(BeanMetaDataFactoryVisitor.java:136)
            at org.jboss.system.server.profileservice.ProfileServiceBootstrap.initBootstrapMDs(ProfileServiceBootstrap.java:433)
            at org.jboss.system.server.profileservice.ProfileServiceBootstrap.start(ProfileServiceBootstrap.java:250)
            at org.jboss.bootstrap.AbstractServerImpl.start(AbstractServerImpl.java:461)
            at org.jboss.Main.boot(Main.java:221)
            at org.jboss.Main$1.run(Main.java:556)
            at java.lang.Thread.run(Thread.java:619)
            Caused by: java.lang.IllegalStateException: ClassLoader has not been set
            at org.jboss.deployers.structure.spi.helpers.AbstractDeploymentUnit.getClassLoader(AbstractDeploymentUnit.java:154)
            at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.addBeanComponent(BeanMetaDataFactoryVisitor.java:60)
            at org.jboss.deployers.vfs.deployer.kernel.BeanMetaDataFactoryVisitor.deploy(BeanMetaDataFactoryVisitor.java:126)
            ... 6 more


            -------------------

            Best regards,

            Sunny

            • 3. Re: fooapp example failed
              Amos Feng Apprentice

              Hi Sunny,

              How about your OS version? Is it WinXP ?
              Did you install VS2008 ?

              It looks like missing VC runtime library. We build blacktie with VS2008 complier and linker.

              So, If you have not installed VS2008, I suggest that download from http://www.microsoft.com/downloads/details.aspx?FamilyID=9b2da534-3e03-4391-8a4d-074b9f2bc1bf&displaylang=en and installed vcredist_x86.exe.

              After that, you can try 'server -c win32 -i 1 ' again.
              Hope this is helpful.

              Amos

              • 4. Re: fooapp example failed
                Chuanbin Xu Newbie

                I'll try it.
                Thanks a lot.

                • 5. Re: fooapp example failed
                  Chuanbin Xu Newbie

                  Hi Amos,

                  I installed vcredist_x86.exe(1.7M), and reboot the PC.

                  But the same error occurred.

                  And there is no blacktie.log under the directory.

                  Is there anything I should do in admin-console?

                  Best regards.

                  Sunny

                  • 6. Re: fooapp example failed
                    Amos Feng Apprentice

                    1. How about your Windows version ? 32bit or 64bit ?

                    2. Did you install VS2008 ?

                    I've test on WinXP 32bit + VS2008, and it works fine.
                    I think you don't need to do in admin-console since no blacktie server running.

                    The most possible problem is about NOT matched dlls, e.g. we build dlls on WinXP but you run on Win2003 or other.

                    • 7. Re: fooapp example failed
                      Tom Jenkinson Master

                      Hi Sunny,

                      Please can you confirm the following information:

                      1. The operating system you are on (e..g Win XP 32bit)
                      2. The version of Java that you are using (java -version)
                      3. You have deployed the stompconnectservice into JBoss
                      4. The version of BlackTie that you are using
                      5. Did you alter and execute setenv.bat appropriately before running "server -c win32 -i 1"
                      6. The specific version of JBoss AS that you are using
                      7. The output from build_server did not generate any errors
                      8. That you have installed VS2008 Express Edition

                      Thanks in advance,
                      Tom

                      • 8. Re: fooapp example failed
                        Chuanbin Xu Newbie

                        Hi Tom and Amos,

                        I'm using XP 32-bit.

                        I installed vcredist_x86.exe only, now I'm downloading the vs2008 express edition and will try it again.

                        Thank you very much for your patience.

                        Best regards,

                        Sunny

                        • 9. Re: fooapp example failed
                          Chuanbin Xu Newbie

                          Hi,

                          I installed vs 2008, and the fooapp works fine now.

                          Thanks a lot.

                          Best regards,

                          Sunny

                          • 10. Re: fooapp example failed
                            Tom Jenkinson Master

                            GREAT! Hope BlackTie works out well for you!