2 Replies Latest reply on Jan 24, 2002 2:09 AM by adoes

    Why JBoss always regards my jvm as 1.2.2?

    adoes Newbie

      I have some problems with installing JBoss 2.4.4 with Tomcat 4.0.1.
      I installed jdk 1.3.1 and added JBOSS_CLASSPATH to system environment as:
      D:\jdk1.3.1\lib\tools.jar;D:\jdk1.3.1\jre\lib\rt.jar
      but JBoss just cannot recognize my jvm. when starting JBoss, I get the following error message:
      --------------------------
      JBOSS_CLASSPATH=D:\jdk1.3.1\lib\tools.jar;D:\jdk1.3.1\jre\lib\rt.jar;run.jar;../
      lib/crimson.jar
      jboss.home = D:\JBoss-2.4.4_Tomcat-4.0.1\jboss
      Using JAAS LoginConfig: file:/D:/JBoss-2.4.4_Tomcat-4.0.1/jboss/conf/default/aut
      h.conf
      JBoss release: JBoss-2.4.4 CVSTag=JBoss_2_4_4
      JBoss version: 2.4.4.2001-12-29 02:04:40 PST
      Using configuration "default"
      [INFO,root] Started Log4jService, config=file:/D:/JBoss-2.4.4_Tomcat-4.0.1/jboss
      /conf/default/log4j.properties
      [INFO,Info] Java version: 1.2.2,Sun Microsystems Inc.
      [INFO,Info] Java VM: Classic VM 1.2.2,Sun Microsystems Inc.
      [INFO,Info] System: Windows NT 5.0,x86
      [ERROR,Shutdown] Could not add shutdown hook
      java.lang.NoSuchMethodError: java.lang.Runtime: method addShutdownHook(Ljava/lan
      g/Thread;)V not found
      ...
      [ERROR,ConfigurationService] Unexpected error
      java.lang.UnsatisfiedLinkError: defineClass0
      ...
      [ERROR,Default] java.lang.RuntimeException: Unexpected Error: defineClass0
      [ERROR,Default] at org.jboss.configuration.ConfigurationService.load(Con
      figurationService.java, Compiled Code)
      [ERROR,Default] at org.jboss.configuration.ConfigurationService.loadConf
      iguration(ConfigurationService.java, Compiled Code)
      [ERROR,Default] at java.lang.reflect.Method.invoke(Native Method)
      [ERROR,Default] at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanSe
      rverImpl.java:1628)
      [ERROR,Default] at com.sun.management.jmx.MBeanServerImpl.invoke(MBeanSe
      rverImpl.java:1523)
      [ERROR,Default] at org.jboss.Main.(Main.java, Compiled Code)
      [ERROR,Default] at org.jboss.Main$1.run(Main.java:110)
      [ERROR,Default] at java.security.AccessController.doPrivileged(Native Me
      thod)
      [ERROR,Default] at org.jboss.Main.main(Main.java, Compiled Code)
      --------------------------
      crimson.jar is just in the lib directory. even i put rt.jar and tools.jar to lib\ext, it still doesn't work. What's wrong with my settings? or some patches are needed? please help. thanks so much.