0 Replies Latest reply on Oct 11, 2002 1:26 PM by Chris Andrade

    Another HTTP 404 variant

    Chris Andrade Newbie

      I really hate to bug the forums with yet another 404 error problem but this is something that I just can't fix and I want to assure you that I've throughly searched the forums, google groups, yahoo, etc.. before posting this question.

      I've started up JBoss(v.3.0.3 w/Tomcat 4.1.12), created a directory called myApp.war in the default/deploy directory and I can view html and jsp pages from the myApp directory. I can't however view servlets. I added the servlet to my web.xml and tried to view it through the URL http://localhost:8080/myApp/servlet/BasicWebServlet and it spits back a 404 error. I can't for the life of me figure out what I'm doing wrong. I took the liberty of checking my server log and the directory myApp.war was included as an "Incompletely deployed package". This was the specific message:

      url=file:/D:/JBoss00/server/default/deploy/myApp.war/ }
      deployer: null
      status: null
      state: INIT_WAITING_DEPLOYER
      watch: file:/D:/JBoss00/server/default/deploy/myApp.war/

      Not sure what that means but it didn't seem to critical an exception because I'm still able to view html/jsp files from that directory.

      I got frustrated to the point where I just downloaded Tomcat just so I could test out my servlets but I'm getting the same error as well. I'm running JBoss off of Windows 2000 advanced server if that helps.

      Thanks in advance.