1 Reply Latest reply on Feb 23, 2003 5:51 PM by Juha Lindfors

    Error using jndi.properties

    Shaolang Newbie

      Hi,

      I just started learning J2EE, and JBoss, as a matter of fact. I've tried included the jndi.properties file in the %JAVA_HOME%\lib directory and even tried setting the classpath as follow:

      set classpath=.;d:\j2ee\lib\j2ee.jar;d:\j2ee\lib\locale;d:\jboss\client\concurrent.jar;d:\jboss\client\jaas.jar;d:\jboss\client\jboss-common-client.jar;d:\jboss\client\jboss-client.jar;d:\jboss\client\jboss-system-client.jar;d:\jboss\client\jboss-jsr77.jar;d:\jboss\client\jbossmq-client.jar;d:\jboss\client\jboss-j2ee.jar;d:\jboss\client\jbosssx-client.jar;d:\jboss\client\jmx-rmi-connector-client.jar;d:\jboss\client\jnet.jar;d:\jboss\client\jnp-client.jar;d:\jboss\client\jsse.jar;d:\jboss\client\jcert.jar;d:\jboss\client\log4j.jar;d:\jboss\server\default\lib\javax.servlet.jar;d:\jboss\server\default\lib\jboss.jar;d:\jboss\server\default\lib\jbosssx.jar;d:\jboss\lib\jboss-system.jar;d:\jboss\lib\jboss-jmx.jar;d:\jboss\server\default\lib\activation.jar;d:\jboss\server\default\lib\mail.jar;d:\jboss\server\default\lib\hsqldb.jar;d:\jboss\server\default\lib\hsqldb-plugin.jar;d:\j2sdk\jndi.properties;

      However, my client program keep getting the environment properties to be:

      java.naming.corba.orb=com.sun.enterprise.iiop.POAEJBORB@110fe28

      instead of the settings in %JAVA_HOME%\lib\jndi.properties

      I'm using J2SDK 1.4.1.01, J2SDKEE 3.1 and JBoss 3.0.4 with Tomcat 4.1.12. Please advise on what should I do. Thanks in advance!