5 Replies Latest reply on Jun 24, 2003 2:18 PM by Jim Dwyer

    3.2.1 - can't run binary distribution

    dlevitt Newbie

      I've downloaded both the binary and source distributions, and so far I can not get the binary distribution to run. [I'm having difficulty with the source too - but thats another posting]

      Enviornment is W2K with JDK 1.4.2

      ===============================================================================
      .
      JBoss Bootstrap Environment
      .
      JBOSS_HOME: C:\bin\JBoss\jboss-3.2.1\bin\\..
      .
      JAVA: c:\j2sdk1.4.2\bin\java
      .
      JAVA_OPTS: -Dprogram.name=run.bat
      .
      CLASSPATH: ;c:\j2sdk1.4.2\lib\tools.jar;C:\bin\JBoss\jboss-3.2.1\bin\run.jar
      .
      ===============================================================================
      .
      09:24:56,546 INFO [Server] Starting JBoss (MX MicroKernel)...
      09:24:56,562 INFO [Server] Release ID: JBoss [WonderLand] 3.2.1 (build: CVSTag=
      JBoss_3_2_1 date=200305041533)
      09:24:56,562 INFO [Server] Home Dir: C:\bin\JBoss\jboss-3.2.1
      09:24:56,562 INFO [Server] Home URL: file:/C:/bin/JBoss/jboss-3.2.1/
      09:24:56,562 INFO [Server] Library URL: file:/C:/bin/JBoss/jboss-3.2.1/lib/
      09:24:56,562 INFO [Server] Patch URL: null
      09:24:56,562 INFO [Server] Server Name: default
      09:24:56,562 INFO [Server] Server Home Dir: C:\bin\JBoss\jboss-3.2.1\server\def
      ault
      09:24:56,578 INFO [Server] Server Home URL: file:/C:/bin/JBoss/jboss-3.2.1/serv
      er/default/
      09:24:56,578 INFO [Server] Server Data Dir: C:\bin\JBoss\jboss-3.2.1\server\def
      ault\data
      09:24:56,578 INFO [Server] Server Temp Dir: C:\bin\JBoss\jboss-3.2.1\server\def
      ault\tmp
      09:24:56,578 INFO [Server] Server Config URL: file:/C:/bin/JBoss/jboss-3.2.1/se
      rver/default/conf/
      09:24:56,578 INFO [Server] Server Library URL: file:/C:/bin/JBoss/jboss-3.2.1/s
      erver/default/lib/
      09:24:56,578 INFO [Server] Root Deployemnt Filename: jboss-service.xml
      09:24:56,593 INFO [Server] Starting General Purpose Architecture (GPA)...
      09:24:56,796 ERROR [Server] Failed to start
      javax.management.InstanceNotFoundException: JMImplementation:service=LoaderRepos
      itory,name=Default
      at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.getMBean(Defaul
      tMBeanServerInterceptor.java:1011)
      at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(DefaultM
      BeanServerInterceptor.java:807)
      at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(JmxMBeanServer.java:791
      )
      at org.jboss.system.server.ServerImpl.initBootLibraries(ServerImpl.java:
      480)
      at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:316)
      at org.jboss.system.server.ServerImpl.start(ServerImpl.java:272)
      at org.jboss.Main.boot(Main.java:150)
      at org.jboss.Main$1.run(Main.java:388)
      at java.lang.Thread.run(Thread.java:534)
      Failed to boot JBoss:

        • 1. Re: 3.2.1 - can't run binary distribution
          mb Newbie

          Hi,

          I'm quite new to Jboss and me too I'm having some problems tryimg to run jboss 3.2.1 It too fails after the GPA:

          18:26:00,753 INFO [Server] Starting JBoss (MX MicroKernel)...
          18:26:00,903 INFO [Server] Release ID: JBoss [WonderLand] 3.2.1 (build: CVSTag=JBoss_3_2_1 date=200305041533)
          18:26:00,903 INFO [Server] Home Dir: C:\Jboss321
          18:26:00,903 INFO [Server] Home URL: file:/C:/Jboss321/
          18:26:00,913 INFO [Server] Library URL: file:/C:/Jboss321/lib/
          18:26:00,913 INFO [Server] Patch URL: null
          18:26:00,913 INFO [Server] Server Name: default
          18:26:00,913 INFO [Server] Server Home Dir: C:\Jboss321\server\default
          18:26:00,913 INFO [Server] Server Home URL: file:/C:/Jboss321/server/default/
          18:26:00,913 INFO [Server] Server Data Dir: C:\Jboss321\server\default\data
          18:26:00,933 INFO [Server] Server Temp Dir: C:\Jboss321\server\default\tmp
          18:26:00,953 INFO [Server] Server Config URL: file:/C:/Jboss321/server/default/conf/
          18:26:00,953 INFO [Server] Server Library URL: file:/C:/Jboss321/server/default/lib/
          18:26:00,953 INFO [Server] Root Deployemnt Filename: jboss-service.xml
          18:26:00,963 INFO [Server] Starting General Purpose Architecture (GPA)...
          18:26:01,394 ERROR [Server] Failed to start
          java.lang.NoClassDefFoundError: EDU/oswego/cs/dl/util/concurrent/ConcurrentReaderHashMap
          at org.jboss.mx.loading.UnifiedClassLoader.(UnifiedClassLoader.java:66)
          at org.jboss.mx.loading.UnifiedClassLoader.(UnifiedClassLoader.java:89)
          at org.jboss.mx.loading.UnifiedClassLoader3.(UnifiedClassLoader3.java:60)
          at org.jboss.mx.loading.UnifiedClassLoader3.(UnifiedClassLoader3.java:72)
          at org.jboss.mx.loading.UnifiedLoaderRepository3.newClassLoader(UnifiedLoaderRepository3.java:121)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:324)
          at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
          at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:549)
          at org.jboss.system.server.ServerImpl.initBootLibraries(ServerImpl.java:480)
          at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:316)
          at org.jboss.system.server.ServerImpl.start(ServerImpl.java:272)
          at org.jboss.Main.boot(Main.java:150)
          at org.jboss.Main$1.run(Main.java:388)
          at java.lang.Thread.run(Thread.java:536)

          I'm using Eclipse 2.1 with Lomboz 2.1 and my configuration is quite the same as yours. Besides your problem, do you know what happens here?

          Regards,

          MB

          • 2. Re: 3.2.1 - can't run binary distribution
            chris6f Newbie

            I am having the same issue with Eclipse/Lomboz. It runs fine outside of the Eclipse environment.

            • 3. Re: 3.2.1 - can't run binary distribution
              chris6f Newbie

              Hi,

              I got this to work in Eclipse.
              Here is what you have to do:

              In Eclipse, go to Windorws->Preferences.
              Then select Lomboz->Server Definitions.
              Select your JBoss server name, mine is JBOSS 3.2.1.
              Then select the Classpath Tab.
              You need to add two libraries to the Server Libraries.
              ${JBOSS}/client/jbossall-client.jar
              and
              ${JBOSS}/lib/jboss-system.jar

              good luck

              • 4. Re: 3.2.1 - can't run binary distribution
                Jim Dwyer Novice

                I am having the same bug as dlevitte. Does anybody know of a solution using W2K and JDK1.4?

                • 5. Re: 3.2.1 - can't run binary distribution
                  Jim Dwyer Novice

                  dlevitte,

                  Looks like my last reply didn't take. JBoss ships with a JBossMX (JBosses implementation of JMX). You need to remove all jmx*.jar classes from your CLASSPATH. This worked for me.

                  Jim