1 Reply Latest reply on Jul 29, 2003 12:52 PM by Juha Lindfors

    Problem running JBoss3.0.2 (binary) in JDK1.4.x

    Nigel Birch Newbie

      Hi,

      I have been running JBoss 3.0.2 on the IBM 1.3JDK. Now I am moving to the IBM 1.4.1 JDK. I have built my app with 1.4.1 but when I run with the 1.4.1 JRE I get the following error in server.log when JBoss starts up:

      01:28:24,760 ERROR [Server] start failed
      org.jboss.deployment.DeploymentException: Could not create deployment: file:/opt/fpdirector-3.0.2/jboss/server/fpdirector/conf/jboss-service.xml; - nested throwable: (java.lang.NoClassDefFoundError: $Proxy0)
      at org.jboss.deployment.MainDeployer.create(MainDeployer.java:772)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:615)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:580)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:564)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:79)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:41)
      at java.lang.reflect.Method.invoke(Method.java:371)
      at org.jboss.mx.capability.ReflectedMBeanDispatcher.invoke(ReflectedMBeanDispatcher.java:284)
      at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:517)
      at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:324)
      at org.jboss.system.server.ServerImpl.start(ServerImpl.java:221)
      at org.jboss.Main.boot(Main.java:142)
      at org.jboss.Main$1.run(Main.java:375)
      at java.lang.Thread.run(Thread.java:568)

      .....etc....

      Can I run the dowloaded binary JBoss3.0.2 on the IBM 1.4.x JRE? Do I have to build Jboss with the 1.4.x JDK to have it run?

      Thanks
      NBirch