7 Replies Latest reply on Sep 29, 2003 5:07 PM by Jon Barnett

    installed jboss but not working

    alihaider Newbie

      Hello everyone,


      I just installed jboss-3.2.2RC4 but its not working.. When I run the server, it shows me in the log that the server is running and it has started MX kernel.. but when I try to view it in the browser at port 8082.. says page not found.. (typical IE error when there is no page to serve).. even if I try to use port 8080.. it gives me the following error from tomcat

      HTTP Status 500 - No Context configured to process this request

      Can somebody plz guide me how to make it work and wats going wrong with it

      Thanks in advance
      Ali

        • 1. Re: installed jboss but not working
          Jon Barnett Master

          There is no root context for Tomcat. Try http://localhost:8080/jmx-console. There is nothing served at port 8082 either.

          • 2. Re: installed jboss but not working
            cathy Newbie

            Hi,

            I have the same problem. I downloaded jboss-3.2.2RC4.zip, extract it and run "run.bat" from bin directory.

            10:12:03,685 INFO [Server] JBoss (MX MicroKernel) [3.2.2RC4 (build: CVSTag=JBo
            s_3_2_2_RC4 date=200309172341)] Started in 24s:455ms

            I then tried to launch http://localhost:8080/jmx-console but received error:
            java.exe generated errors and will be closed by windows. YOu will need to restart the program.

            Please help! Am I missing any steps or doing something wrong? Thanksssssss

            Cathy

            • 3. Re: installed jboss but not working
              Jon Barnett Master

              You would need to capture the errors that java.exe generated, but it sounds like the JVM is crashing. I would suggest trying a different JVM version.

              • 4. Re: installed jboss but not working
                cathy Newbie

                HI,

                I just re-install the SDK 1.4.1 and re-start computer. THen, I re-install the jboss but still have the same problem. Here's the exact error message when I tried to launch http://localhost:8080/jmx-console/index.jsp

                Do I need to set up TOMCAT home directory? Or install TOMCAT seperate?

                Thanks

                Please help!


                HTTP Status 500 -

                --------------------------------------------------------------------------------

                type Exception report

                message

                description The server encountered an internal error () that prevented it from fulfilling this request.

                exception

                org.apache.jasper.JasperException: Unable to compile class for JSP

                An error occurred at line: -1 in the jsp file: null

                Generated servlet error:
                [javac] Compiling 1 source file



                at org.apache.jasper.compiler.DefaultErrorHandler.javacError(DefaultErrorHandler.java:130)
                at org.apache.jasper.compiler.ErrorDispatcher.javacError(ErrorDispatcher.java:293)
                at org.apache.jasper.compiler.Compiler.generateClass(Compiler.java:353)
                at org.apache.jasper.compiler.Compiler.compile(Compiler.java:370)
                at org.apache.jasper.JspCompilationContext.compile(JspCompilationContext.java:473)
                at org.apache.jasper.servlet.JspServletWrapper.service(JspServletWrapper.java:190)
                at org.apache.jasper.servlet.JspServlet.serviceJspFile(JspServlet.java:295)
                at org.apache.jasper.servlet.JspServlet.service(JspServlet.java:241)
                at javax.servlet.http.HttpServlet.service(HttpServlet.java:853)
                at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:247)
                at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:193)
                at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:256)
                at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:643)
                at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:480)
                at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:995)
                at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
                at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:643)
                at org.jboss.web.tomcat.security.JBossSecurityMgrRealm.invoke(JBossSecurityMgrRealm.java:228)
                at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:641)
                at org.apache.catalina.valves.CertificatesValve.invoke(CertificatesValve.java:246)
                at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:641)
                at org.jboss.web.tomcat.tc4.statistics.ContainerStatsValve.invoke(ContainerStatsValve.java:76)
                at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:641)
                at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:480)
                at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:995)
                at org.apache.catalina.core.StandardContext.invoke(StandardContext.java:2416)
                at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:180)
                at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:643)
                at org.apache.catalina.valves.ErrorDispatcherValve.invoke(ErrorDispatcherValve.java:171)
                at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:641)
                at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:172)
                at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:641)
                at org.jboss.web.tomcat.security.SecurityAssociationValve.invoke(SecurityAssociationValve.java:65)
                at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:641)
                at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:577)
                at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:641)
                at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:480)
                at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:995)
                at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:174)
                at org.apache.catalina.core.StandardPipeline$StandardPipelineValveContext.invokeNext(StandardPipeline.java:643)
                at org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:480)
                at org.apache.catalina.core.ContainerBase.invoke(ContainerBase.java:995)
                at org.apache.coyote.tomcat4.CoyoteAdapter.service(CoyoteAdapter.java:223)
                at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:601)
                at org.apache.coyote.http11.Http11Protocol$Http11ConnectionHandler.processConnection(Http11Protocol.java:392)
                at org.apache.tomcat.util.net.TcpWorkerThread.runIt(PoolTcpEndpoint.java:565)
                at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:619)
                at java.lang.Thread.run(Thread.java:536)


                • 5. Re: installed jboss but not working
                  Raja Master

                  set your JAVA_HOME environment variable to where you installed Java.
                  Tomcat needs this for compiling the JSPs.

                  -Raj

                  • 6. Re: installed jboss but not working
                    cathy Newbie

                    Hi,
                    I did but it still not working. The funny thing is that I tried on my friend computer with the same procedure and it works! I don't know what's wrong with my environment setting b/c I had J2EE_HOME and JAVA_HOME set to the correct location.

                    :-(

                    • 7. Re: installed jboss but not working
                      Jon Barnett Master

                      Looks like Ant can't kick off the compiler for the JSP task. If you have installed the JDK with a directory path that contains a space, re-install to a directory path that does not contain a space. Also do the same for JBoss.