3 Replies Latest reply on Oct 6, 2003 5:42 AM by Juha Lindfors

    JBoss fails to boot

    amidechat Newbie

      Hi,

      I just downloaded and installed jboss3.2.1_tomcat-4.1.24 binary into a directory with no spaces on Win2K.

      When I tried run.bat, this is what I got:


      C:\>cd %JBOSS_HOME%\bin

      C:\Programs\jboss-3.2.1_tomcat-4.1.24\bin>run.bat
      ===============================================================================
      .
      JBoss Bootstrap Environment
      .
      JBOSS_HOME: C:\Programs\jboss-3.2.1_tomcat-4.1.24\bin\\..
      .
      JAVA: C:\Programs\j2sdk1.4.2_01\bin\java
      .
      JAVA_OPTS: -Dprogram.name=run.bat
      .
      CLASSPATH: ;C:\Programs\j2sdk1.4.2_01\lib\tools.jar;C:\Programs\jboss-3.2.1_to
      mcat-4.1.24\bin\\run.jar
      .
      ===============================================================================
      .
      Failed to boot JBoss:
      java.lang.ClassNotFoundException: org.jboss.system.server.ServerImpl
      at java.net.URLClassLoader$1.run(URLClassLoader.java:199)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
      at org.jboss.system.server.ServerLoader.createServer(ServerLoader.java:2
      41)
      at org.jboss.system.server.ServerLoader.load(ServerLoader.java:224)
      at org.jboss.Main.boot(Main.java:142)
      at org.jboss.Main$1.run(Main.java:388)
      at java.lang.Thread.run(Thread.java:534)
      Press any key to continue . . .
      C:\Programs\jboss-3.2.1_tomcat-4.1.24\bin>

      Here's my classpath:
      C:\Programs\jboss-3.2.1_tomcat-4.1.24\bin>
      set classpath
      CLASSPATH=C:\Programs\j2sdk1.4.2_01\jre\lib;
      C:\Programs\j2sdk1.4.2_01;
      C:\Programs\j2sdk1.4.2_01\jre\lib\rt.jar;
      C:\Programs\j2sdk1.4.2_01\lib\tools.jar;.\;
      C:\Programs\junitperf\lib\junitperf.jar;
      C:\Programs\apache-ant-1.5.4\lib\ant.jar;
      C:\Programs\j2sdkee1.3.1;C:\Programs\jaxb\lib;
      C:\Programs\jboss-3.2.1_tomcat-4.1.24\bin;
      C:\Programs\jboss-3.2.1_tomcat-4.1.24\lib;
      C:\demo\webapp\first\lib;
      C:\Programs\jboss-3.2.1_tomcat-4.1.24;
      C:\Programs\jboss-3.2.1_tomcat-4.1.24\server\default\lib;
      C:\Programs\jboss-3.2.1_tomcat-4.1.24\server\all\lib

      Has anyone had this problem. Please help!
      Thank you in advance.