2 Replies Latest reply on Jan 4, 2004 4:40 PM by Ed Hillmann

    Problem in Installing and Running JBoss 4 on Windows 2003 se

    kannan duraisamy Newbie

      Hi,
      I have dowloaded the latest JBoss 4 and trying to install in a Windows 2003 enterprise server. I use Java 1.4 latest edition. When i run the run.bat, i get lots of exceptions thrown in the console and the server starts up. The admin port 8080 is opened ,the netstat also shows the the port as Time wait and then disappears. Bcos of this im not able to view the jmx-console. Have anyone come across similar problems?. Are there any special settings to be done on the server?
      Your help is greatly appreciated. Thanx in advance.

      Kan D.

        • 1. Re: Problem in Installing and Running JBoss 4 on Windows 200
          Ed Hillmann Newbie

          Did you ever find anything out about this? I think I'm experiencing the same. I had installed Jboss 4 with Java 1.4.2 on a Windows 98 box, and it worked fine. When I upgraded the box to Windows 2000 (no SP), it starts but nothing is available. The server log has heaps of messages like

          2004-01-04 15:04:42,590 DEBUG [org.jboss.management.j2ee.MBean]
          postRegister(), parent:
          jboss.management.local:J2EEServer=Local,j2eeType=ServiceModule,name=jboss-se
          rvice.xml
          2004-01-04 15:04:42,600 DEBUG [org.jboss.management.j2ee.MBean] Failed to
          initialze state from: jboss.rmi:type=RMIClassLoader
          java.lang.IllegalArgumentException: Unable to find operation getState()
          at
          org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:13
          3)
          at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:544)
          at
          org.jboss.mx.util.JMXInvocationHandler.invoke(JMXInvocationHandler.java:272)
          at $Proxy13.getState(Unknown Source)

          Just curious if you've made any progress. I'm going to apply Win2K SP 4 soon, so I wonder if that's involved....

          • 2. Re: Problem in Installing and Running JBoss 4 on Windows 200
            Ed Hillmann Newbie

            Did you ever find anything out about this? I think I'm experiencing the same. I had installed Jboss 4 with Java 1.4.2 on a Windows 98 box, and it worked fine. When I upgraded the box to Windows 2000 (no SP), it starts but nothing is available. The server log has heaps of messages like

            2004-01-04 15:04:42,590 DEBUG [org.jboss.management.j2ee.MBean]
            postRegister(), parent:
            jboss.management.local:J2EEServer=Local,j2eeType=ServiceModule,name=jboss-se
            rvice.xml
            2004-01-04 15:04:42,600 DEBUG [org.jboss.management.j2ee.MBean] Failed to
            initialze state from: jboss.rmi:type=RMIClassLoader
            java.lang.IllegalArgumentException: Unable to find operation getState()
            at
            org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.java:13
            3)
            at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:544)
            at
            org.jboss.mx.util.JMXInvocationHandler.invoke(JMXInvocationHandler.java:272)
            at $Proxy13.getState(Unknown Source)

            Just curious if you've made any progress. I'm going to apply Win2K SP 4 soon, so I wonder if that's involved....