1 Reply Latest reply on Oct 12, 2004 11:26 AM by Scott Stark

    Firewall - RmiPort - HTTP Tunneling

    pclarke Newbie

      Can anyone confirm that it is possible to fix the dynamically
      generated RMI port number when you are trying to use
      HTTP tunneling. Numerous posts have suggested that you need to
      set the following value in jboss-service.xml file:

      <mbean code="org.jboss.naming.NamingService"
       name="jboss:service=Naming">
       <!-- The listening port for the bootstrap JNP service. Set this to -1
       to run the NamingService without the JNP invoker listening port.
       -->
       <attribute name="Port">1099</attribute>
       <attribute name="RmiPort">XXXX</attribute>
      </mbean>
      


      where XXXX is the port number you wish to be used instead of
      the dynamically generated one which changes each time you
      stop/restart JBoss.

      I've tried the above change but I still always get a different
      port number when I stop/restart JBoss.

      Am I doing something wrong or configuring the wrong file or
      parameter? Any help/suggestion welcome.

      Also, has anyone been be able to implement a servlet that performs
      the required cgi-bin/java-rmi.cgi functionality on the server side.


      I'm using JBoss 3.2.1 with integrated Tomcat-4.1.24