5 Replies Latest reply on Dec 16, 2004 7:39 PM by david su

    error when run the run.bat command

    david su Newbie

      dear sir/madam:

      in installed the j2ee 1.4 jdk and the jboss-4.0.0, then follow the tutorial startguide to run the run.bat command and get the following error. it will be very appreciated if you can direct me to the right direction on what could be the problem to lead to this error.

      thanks!
      david


      F:\Java_C++\JavaFrameWork\JBoss\jboss-4.0.0\bin>run.bat
      ===============================================================================
      .
      JBoss Bootstrap Environment
      .
      JBOSS_HOME: F:\Java_C++\JavaFrameWork\JBoss\jboss-4.0.0
      .
      JAVA: E:\Sun\AppServer\jdk\bin\java
      .
      JAVA_OPTS: -Dprogram.name=run.bat -Xms128m -Xmx512m
      .
      CLASSPATH: E:\Sun\AppServer\jdk\lib\tools.jar;F:\Java_C++\JavaFrameWork\JBoss\
      jboss-4.0.0\bin\run.jar
      .
      JAVA_HOME: E:\Sun\AppServer\jdk
      . ==============================================================================
      =
      .
      Failed to boot JBoss:
      java.lang.ClassNotFoundException: org.jboss.system.server.ServerImpl
      at java.net.URLClassLoader$1.run(URLClassLoader.java:199)
      at java.security.AccessController.doPrivileged(Native Method)
      at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
      at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
      at org.jboss.system.server.ServerLoader.createServer(ServerLoader.java:2
      71)
      at org.jboss.system.server.ServerLoader.load(ServerLoader.java:253)
      at org.jboss.Main.boot(Main.java:143)
      at org.jboss.Main$1.run(Main.java:405)
      at java.lang.Thread.run(Thread.java:534)
      Press any key to continue . . .
      F:\Java_C++\JavaFrameWork\JBoss\jboss-4.0.0\bin>