1 Reply Latest reply on May 5, 2005 6:51 AM by Andrew Wagg

    Using a different Name Service

    Andrew Wagg Newbie

      This probaly is a user question, although this seems to be the best place to ask.

      I am trying to use a name server (TAO) on a different server and have modified the jacorb.properties to use this by adding the following line.

      ORBInitRef.NameService=corbaloc:iiop:wk20:2809/NameService

      I turned on additional debugging and get the following information.

      INFO | jvm 1 | 2005/05/04 12:10:55 | 11:10:55,625 INFO [STDOUT] [ InterceptorManager started with 0 SIs, 0 CIs and 2 IORIs ]
      INFO | jvm 1 | 2005/05/04 12:10:55 | 11:10:55,670 INFO [STDOUT] [ Delegate.getReference with POA < empty> ]
      INFO | jvm 1 | 2005/05/04 12:10:55 | 11:10:55,829 INFO [STDOUT] [ ClientConnectionManager: created new conn to target wk20:280
      9 ]
      INFO | jvm 1 | 2005/05/04 12:10:55 | 11:10:55,830 INFO [STDOUT] [ (Pool)[0/0] creating new thread ]
      INFO | jvm 1 | 2005/05/04 12:10:55 | 11:10:55,876 INFO [STDOUT] [ (Pool)[1/1] added idle thread ]
      INFO | jvm 1 | 2005/05/04 12:10:55 | 11:10:55,876 INFO [STDOUT] [ (Pool)[0/1] removed idle thread (job scheduled) ]
      INFO | jvm 1 | 2005/05/04 12:10:56 | 11:10:56,775 INFO [STDOUT] [ Trying to connect to 10.141.65.174:2809 ]
      INFO | jvm 1 | 2005/05/04 12:10:56 | 11:10:56,780 INFO [STDOUT] [ Connected to wk20:2809 from local port 4989 ]
      INFO | jvm 1 | 2005/05/04 12:10:56 | 11:10:56,829 INFO [STDOUT] [ Delegate.getReference with POA < empty> ]
      INFO | jvm 1 | 2005/05/04 12:10:56 | 11:10:56,834 INFO [STDOUT] [ Closed client-side TCP/IP transport to wk20:2809 terminally
      ]
      INFO | jvm 1 | 2005/05/04 12:10:56 | 11:10:56,835 INFO [STDOUT] [ GIOPConnection closed completely ]
      INFO | jvm 1 | 2005/05/04 12:10:56 | 11:10:56,836 INFO [STDOUT] [ ClientConnectionManager: found conn to target wk20:2809 ]
      INFO | jvm 1 | 2005/05/04 12:10:56 | 11:10:56,854 INFO [STDOUT] [ Transport to wk20:2809: stream closed ]
      INFO | jvm 1 | 2005/05/04 12:10:56 | 11:10:56,855 INFO [STDOUT] [ Closed client-side TCP/IP transport to wk20:2809 terminally
      ]
      INFO | jvm 1 | 2005/05/04 12:10:56 | 11:10:56,856 INFO [STDOUT] [ (Pool)[1/1] added idle thread ]
      INFO | jvm 1 | 2005/05/04 12:10:56 | 11:10:56,856 INFO [STDOUT] [ (Pool)[1/1] job queue empty ]

      It seems it just conencts and disconnects from the name server.

      Any suggestions, am I going about this the right way by using a different name server.

      Thanks

      Andy