0 Replies Latest reply on Jun 17, 2005 1:36 PM by john guthrie

    DeploymentException for jboss as windows service

    john guthrie Newbie

      using the second method enumerated at http://jboss.org/wiki/Wiki.jsp?page=RunJBossAsAServiceOnWindows (since the first requires a JAVA_HOME free of spaces and the one i need to deploy this to is in Program Files) i set up jboss as a service. it all seemed to go fine, but...

      i get a deployment exception on my webapp. i basically have added two webapps to my server - jakarta slide's slide.war and my own little webapp. both have worked fine for months. but when i try to start up my jboss windows service, i get a DeploymentException saying that jboss cannot find file:/d:/jboss-4.0.1sp1/server/myserver/deploy/myapp.war (i may have munged the path, but you get the idea), and asking me if i am sure it exists. it does - how else would jboss know i wanted to deploy it? and slide.war deploys just fine, as if to taunt me.

      as i said, running run.bat from a shell, all goes well. running wrapper's wrapper shell from a shell, all goes well. running wrapper as a service, odd error.

      oh yes, and one of my HARs, which i created but am not using, gives me the same error...

      any ideas welcome. thanks.