0 Replies Latest reply on Dec 29, 2005 12:28 PM by Aquila Deus

    Very Slow App Loading with Sun JDK

    Aquila Deus Newbie

      Hi all!

      Does anyone know why JBoss with Sun JDK takes forever to startup and load web-apps?


      Following is what my log shows:

      (JBoss 4.0.3SP1, with everything enabled in the jar installer)

      Sun JDK 1.5.0_04,
      JAVA_OPTS: -server -noverify -Xms32m -Xmx512m -XX:MaxPermSize=384m

      Startup:

      [Server] JBoss (MX MicroKernel) [4.0.3SP1 (build: CVSTag=JBoss_4_0_3_SP1 date=200510231751)] Started in 1m:36s:694ms


      Deploy tapestry 4.0 "forms" example:
      [ApplicationServlet] Initialized application servlet 'forms': 4,987 millis to create HiveMind Registry, 10,225 millis overall.
      


      Reload "forms" example:
      [ApplicationServlet] Initialized application servlet 'forms': 1,422 millis to create HiveMind Registry, 4,119 millis overall.
      



      BEA JRockit 1.5.0_04,
      JAVA_OPTS: -server -noverify -Xns24m -Xms32m -Xmx512m -Xgcprio:throughput

      Startup:
      [Server] JBoss (MX MicroKernel) [4.0.3SP1 (build: CVSTag=JBoss_4_0_3_SP1 date=200510231751)] Started in 1m:11s:454ms


      Deploy tapestry 4.0 "forms" example:
      [ApplicationServlet] Initialized application servlet 'forms': 2,834 millis to create HiveMind Registry, 3,984 millis overall.
      


      Reload "forms" example:
      [ApplicationServlet] Initialized application servlet 'forms': 259 millis to create HiveMind Registry, 842 millis overall.
      



      Currently the application server doesn't host any other apps.

      My system is AMD Sempron(tm) 2400+, 1.5GB RAM, Arch Linux (kernel 2.6.14.3)