2 Replies Latest reply on Jun 1, 2006 4:13 PM by Peter Johnson

    JBoss 4.0.4 deployment exception: Could not open jboss-servi

    Michael Cohen Newbie

      Hi,

      I'm a JBoss newbie. I just started getting into the application to help me learn J2EE v5. I installed JBoss successfully onto my Windows system, however, when I try to run JBoss I get the following exception spat out:

      Failed to boot JBoss:
      org.jboss.deployment.DeploymentException: url file:/C:/Program Files/jboss-4.0.4
      .GA/server/all/conf/jboss-service.xml could not be opened, does it exist?
      at org.jboss.deployment.DeploymentInfo.(DeploymentInfo.java:211)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:770)
      at org.jboss.deployment.MainDeployer.deploy(MainDeployer.java:755)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.
      java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAcces
      sorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.jboss.mx.interceptor.ReflectedDispatcher.invoke(ReflectedDispatch
      er.java:155)
      at org.jboss.mx.server.Invocation.dispatch(Invocation.java:94)
      at org.jboss.mx.server.Invocation.invoke(Invocation.java:86)
      at org.jboss.mx.server.AbstractMBeanInvoker.invoke(AbstractMBeanInvoker.
      java:264)
      at org.jboss.mx.server.MBeanServerImpl.invoke(MBeanServerImpl.java:659)
      at org.jboss.mx.util.MBeanProxyExt.invoke(MBeanProxyExt.java:210)
      at $Proxy5.deploy(Unknown Source)
      at org.jboss.system.server.ServerImpl.doStart(ServerImpl.java:482)
      at org.jboss.system.server.ServerImpl.start(ServerImpl.java:362)
      at org.jboss.Main.boot(Main.java:200)
      at org.jboss.Main$1.run(Main.java:464)
      at java.lang.Thread.run(Thread.java:595)
      13:34:44,562 INFO [Server] Runtime shutdown hook called, forceHalt: true
      13:34:44,562 INFO [Server] JBoss SHUTDOWN: Undeploying all packages
      13:34:44,562 INFO [Server] Shutdown complete
      Shutdown complete
      Halting VM

      I checked out the server/all folder to find no conf folder, hence no jboss-service.xml file.

      Any idea what I should do to fix the problem. (Yes, I did try reinstalling JBoss but I just kept getting the same problem).

      Any help would be greatly appreciated. Thanks

      Mike